PF2E - Failed to connect to database

Hi all,

I have updated my Foundry to v11 and everything is working fine, except Compendiums. Some Compendiums from modules are working, but main ones from PF2E are not. As everything is working on my PC, can someone tell me if this is The Forge issue or I did something wrong ?

Thnx George

Hey @djole :wave:

This is likely due to v11 requiring compendium packs to specify type rather than entity.
This is a change that affects and compendiums that were made during early v10 or before v10, so it’s possible it’s what’s going on here.

You export your shared compendiums, export them from Forge and look inside them for their module.json files.

Look for packs and check to make sure it has type, not entity. It can have both type and entity, so long as it has type.


If this is indeed the problem, then you can add the type manually and save the module.json file, then use the Import Wizard to import that compendium package back up to Forge, where it should now work :slight_smile:

Hope that helps! Let me know if you get stuck on something or if that is not it

@phi That sounds like fun. Can you tell me how can I access shared compendiums ?

Thnks George

Found it ! Will se if it’s going to work.


Ah, good! Sorry for the late reply earlier! This article should help you out, please shout if you get stuck!

Another possibility if you are on v11, this error can happen when multiple Foundry servers are running at the same time using Game Manager and with multiple licenses. If this is the case, please Stop your other worlds on The Forge before trying to launch your world!

We’ve got a prospective solution for the above which we are in the process of implementing.

Hi again.
I tried with export and couldn’t find any of original PF2E compendiums in list of compendiums to export.
After that I tried your backup option and I did finish backup, but again, I couldn’t find any of original PF2E compendiums !
Just to clarify : I don’t have access to following folders (with original Compendiums)

  • Actors
  • Bestiary
  • Default
  • Item
  • Journal Entry
  • Scene

Other Compendiums which are received from other modules are ok.

Brgds George

And just to add, when I return to main Foundry screen, I have like 80 errors. They are all looking like this one
Failed to connect to database “pf2e.hazards”: Database is not open


Hey George :wave:

Yeah, that sounds like the multiple compendiums issue in v11 due to multiple processes. Do you have multiple Foundry licenses?

We’ve got a prospective solution but this is currently largely unique to the Forge and a part of why we don’t recommend v11 on The Forge yet.

Hello Phi,
I have one license and I’m the only user. I was using Forge on Firefox and recently I started to test how game works on Microsoft Edge… might be that… will logout from one of browsers and stay on only one.

Hmm, alright, that’s unusual and likely not the issue I was referring to in that case. But something is preventing those leveldb databases from opening, then.

It’s quite rare, but one of the pf2e troubleshooting tips is to uninstall and re-install the system. I assume that at some point there might have been a process that could edit or somehow corrupt the system’s packs.

If you’re still stuck, please go ahead and Uninstall + Re-install the pf2e system here The Forge and then Stop and Start your server at The Forge. It may be a shot in the dark, but it is worth a try when running into something that’s difficult to troubleshoot in other means.

If you’re still stuck after trying that, please make a ticket in the #ticket-support channel of the Discord server and post an invite to your game. Maybe I can hop in there with you to get some more troubleshooting in :slight_smile:

Hi Phi,
Reinstall of PF2E worked. Knowing how everything works in windows, I should presume
that reinstall would work… my bad.

Thnx Phi.