Issues Loading Latest Version of Pathfinder 2e

Hey! My game has been having issues loading the latest version of Pathfinder 2e since a few months ago. It installed fine in my other games, but specifically one of my games just opens on “Applying Pathfinder2e System Migration to version Please be patient and do not close your game or shut down your server.” And it sits on that forever, never actually finishing.

While I’m at it, though, my game routinely takes forever to load (anywhere from 10 seconds to a minute or more, some of my players it takes 5 minutes), it just leaves me on the grey cloth texture, and disconnects me from the Forge server every 2-3 minutes, only to reconnect 5-10 seconds later (perhaps connected to it not being able to install the latest PF2e properly, as it disconnected me while installing?) And if it ever hitches for too long, and I reload to powercycle, it makes me log in again, even if I just logged in 30 seconds prior. Any idea? I’ve tried disabling all of my modules, and it didn’t help. Should I be deleting scenes after using them? Will memory be causing a clogging issue?

Alright, so this is probably a multi-pronged problem, let me try to explain.

  1. Good job on trying the Disable All Modules, that can definitely help (run through this to get troublemaker modules permanently disabled: Trouble with Modules)
  2. The Pathfinder 1 and Pathfinder 2e game systems are HUGE. This means those migrations do indeed take a lot of time, which is what you’re seeing. You can open the Dev Console on your browser (Press F12), and click the “Console” tab to watch what it’s doing. It SHOULD be outputting logs there as it works through things (hopefully giving you some indicator as to where it’s at in the process)
  3. Slimming a world down can definitely help, no doubt about that. Give this FAQ a look to see how you’re sitting for World Size: World Size Check

Overall, this might just be a waiting game, but give those a try, see how it comes out.

I just opened a world I haven’t used in 10 months, and it updated to the latest PF2e in 20 seconds. This one will sit on “loading” for 5 hours. It’s definitely not a waiting problem, it’s a problem with its installation. I was hoping to talk to technical support of Forge, but it doesn’t seem like they have one? Not sure.

Also, how do I check how big any given world is? 'Cause I just opened that world previously mentioned and it opened nice and quickly, no hitches at all, and it still had modules loaded.

EDIT: Nevermind on the world size thing, clicked the link you gave me. Sorry.

Just to clarify, I’m one of the Moderators on The Forge Discord, and what I ran through in my last post was indeed technical help.

Checking world size: World Size Check
Clean out things you don’t need into Compendiums. Slim the world down. If the world won’t migrate, it’s an issue with the world in all likelihood. Watch the Dev Console (Press F12) for Migration progress, and especially for Errors (Red Text).

The Module part is to help you going forward, as you can clean out things that would cause you other issues with FoundryVTT Performance: Trouble with Modules

Alright, thanks. I’ll watch, but 3/4 of the time the world doesn’t even load. It just sits on the gray background. Next time it loads, I’ll look for errors.

I have all the modules disabled while I try to work this out. And regarding size, my world is what the article would consider “Large” (15.2MB), but it says problems start around 30, so it seems like it shouldn’t be that big of a deal? Not sure, I might just copy the journal entries into a compendium and make a new world. Might be easier than trying to fix whatever’s going on.

The most important part of the World Size Check (I wrote that :smiley: ) is WHERE the size is at. Is it your chat.db? If so, delete the chat log when you get in-game (having that inflated can cause major loading problems).

If it doesn’t load reliably, same suggestion as above, watch the Dev Console (Press F12, click “Console” tab) for Errors (Red Text). We need to see if it’s erroring out in some way that we can work through.

So, I checked the file sizes, and the largest files by far are Scenes (59,719KB), Actors (4,493KB), and Fog (2,569KB). The rest are all under 250. So, I suppose I SHOULD be deleting scenes after using them. :stuck_out_tongue:

And while I haven’t gotten the world to load back up yet, it’s just hanging on the gray screen, I can tell you this is the console log of the last few minutes.

Foundry VTT | Reestablishing existing session w599b5lzw3hf78byjcqq9ndl  foundry.js:6348
Foundry VTT | Connected to server socket using session w599b5lzw3hf78byjcqq9ndl  foundry.js:6386
Foundry VTT | The game World is currently active 2 foundry.js:6421
Foundry VTT | Connected to server socket using session w599b5lzw3hf78byjcqq9ndl foundry.js:6386

Okay, I did get it to load, and it did receive an error early on.

main.bundle.js:1 PF2E | Flat modifier requires at least a selector field, a label field or item name, and a non-zero value field
|async function (async)|||
|async function (async)|||
|async function (async)|||

Also, it’s still sitting on Installing PF2e, and these are the last two things on the console (the last line of which has loaded three times, due to the disconnections).

Foundry VTT | Retrieved and compiled template templates/sidebar/scene-directory.html
3foundry.js:6386 Foundry VTT | Connected to server socket using session w599b5lzw3hf78byjcqq9ndl\

That is a massively huge world :grimacing: , yeah, either Delete, or get the unused scenes into Compendiums (Shared Compendiums are great: How to share content between worlds, especially for things like scene re-use).

The error… I’d take that to the FoundryVTT Discord and the pf2e channel, show them that error on migration. See if they’ve got anything for you. That sure sounds like it hits SOMETHING in your world, and just stops trying to migrate…

UPDATE: It did come back with a legit error. Here’s what I’ve got.

SAgUAQ2UBf4EeNP3.png:1 Failed to load resource: the server responded with a status of 404 ()
foundry.js:4503 Foundry VTT | Rendering Dialog
foundry.js:5956 Foundry VTT | Retrieved and compiled template templates/hud/dialog.html
foundry.js:5956 Foundry VTT | Retrieved and compiled template templates/app-window.html
foundry.js:6386 Foundry VTT | Connected to server socket using session w599b5lzw3hf78byjcqq9ndl

(If you’d like, you can also join us on Discord, feel free to ping me there)

Ah, that’s some image not loading, if you can find that full link you could run that down. That’s a super random file name though.

Okay, so, I apologize for my incredible lack of hipness here, but I’ve only used Discord for RPG chat channels for specific games. So, I’m not entirely sure what this entails. Do I PM someone in there, or just… post in the chat with my problem?

By no means do you have to join there, up to you, but you can @aeristoka me there too :smiley:

I have both joined and messaged you, as requested. I… don’t see a Pathfinder 2e channel, though? Sorry, I’m super not up on this. :stuck_out_tongue: