Updating to V11

Good morning, I hope,

Last night I updated to v11; I was assured everything should move along swimmingly and, in truth, this was the first time I felt safe updating so quickly after a version release. It took me six weeks after v10 was released before I received a poorly worded notification I needed to update, here, or lose the ability to run the two games I run. Apparently, my mental math is all buggered and, from now on, I think I’ll just wait the several weeks before I perform an update.

If everything had gone as it was supposed to, I wouldn’t be here.

My world for the Torg game system (was known as “Possibility War 776” on v10-288, attached to torgtest) would not even load for v11. For all my guys who work on the Torg Game System, all but one have gone without problems, so I can only conclude I had something set up wrong. I’ve tried to use the import wizard to set up my “Possibility War 776” world, using torgtest as its previous directory, but I wanted to rename that directory when I found out it was not working on the new world I had set up for Torg.

I haven’t the foggiest idea what else I could have screwed up, but torgtest is not working, the new world I set up is not working, when I used the wizard to set up the old world separately, the old world doesn’t show up in my world list. All of my assets remain in the Assets Library, so I’m not terribly worried about that, but the worlds and the modules I had all set up are inaccessible through version 11.

Since the database had not yet migrated, I tried to go back to v10-288 and Torg does not show up there, now, either. So, I tried coming back and rebuilding the world and, from the wizard, the database showed as being migrated, but I’m still not able to get to anything, my Player’s list is totally gone, I’ll have to rebuild that, but I don’t know if I missed a step or if I’ve just completely borked my game as a result of this upgrade silliness.

If anyone would be keen to help me, I would be grateful, please?

However, I don’t have time, right this minute… I’ve paid bills, now I have to put food in the house. Back soon.

Hey there @tithenon :wave:

Sorry to hear that you’ve run into some issues with v11 update. We do generally wait a while before recommending the update to a new version, just to give modules a chance to catch up and for any bugs that do surface to be addressed.

That said, it should be possible to get everything back up to speed. First, you will need to decide if you want to stick with v11 and smooth it out, or whether you want to go back to v10.

Option A: Stick with v11

If you want to stick with v11, switch your Foundry server version to v11.299, and then go to the Bazaar and make sure to update your modules and systems to v11 versions. Torg does have a v11 compatible release on the Bazaar here (but you’ll only see it if your Foundry version is set to v11).

Then, go to the game configuration screen and use the Import Wizard to import the backup you made before switching to v11. This will be a v10 backup, and we will attempt to re-migrate it to v11. Make sure that you launch your world in safe configuration to eliminate modules and module versions as variables.

If that works, you’re set to continue and start enabling modules again. Otherwise: Option B.

Option B: Rollback to v10

Switch your Foundry server version to v10.291 (v10.291 is the most stable and recent of the v10 versions, so I do recommend switching to that instead, but you can use v10.288 instead if you like).

Then, go to the Bazaar and make sure to update your modules and systems to v10 versions instead of v11 versions.

After that, Then, go to the game configuration screen and use the Import Wizard to import the backup you made before switching to v11. Now, make sure that you launch your world in safe configuration to eliminate modules and module versions as variables.

This should do the trick. If you think that the pre-v11 backup you have might not be working, I recommend taking a look at Save Points. We may have a backup of your v10 world even if you were not on World Builder tier at the time since we take daily backups for all users.

With both Option A and Option B, make sure you look at your dev tools console (F12 in your browser when you start up the world) and your Foundry Server logs (on game configuration screen, see image) for signs of what might be going wrong.

Hope this helps you out! If you’re running into issues restoring the backup, please do shout! And if you see any specific errors in the logs that might tell us why the world is not starting up, please post them as screenshots :slight_smile:

Thank you for taking this on, phi; I’m grateful.

I am sticking with v11 and my configuration is set to v11-299. Updating in the Bazaar? I updated, earlier, through the Foundry interface, itself… let me go to update in the Bazaar, as I have my configuration open in another tab. Yes, that’s done. I had two updates to make, one of which was updating from 2.8.3 to 2.9.2 for Torg.

Okay, I used the Import Wizard after changing to v11, earlier today, prior to getting out to put food in the house. Am I allowed to change the name of the game world… wait… I think I have an idea, here…

Torg: Possibility War has the pause symbol in front of it on the game configuration screen instead of what I would term a pause block symbol… let me see if I can log in at this point… I’ll do this through the Foundry window instead of the Google Chrome window I’m using, here, and on a second screen, hehe. It still only has the Gamemaster for my login… let me see if anything else is there from my… System Migration Complete… no, nothing has been re-established. Let me continue step-by-step with your answer…

Okay, I’ve Imported both my worlds and modules backup zip files and, once I overwrote everything, everything came up with success… now, to test it… heart’s beating out of my chest, here… nothing.

Okay, no matter what I do, I can’t get the world to show up for Option A. I’ve shut down and re-opened twice, I’ve tried to remove the new Torg game world, but it won’t go anywhere, I can’t change the data path back to torgtest… this is turning into a humongous charlie-foxtrot, at this point.

Since I’ve tried everything in Option A and it’s changed nothing, I’m going to attempt to set back to v10-291, as you’ve recommended, get rid of the bad world, create a new world with the proper data path, and do all you’ve recommended. Why can’t I get rid of the world in v11? Hmmm…

Okay, I got everything done for re-establishing my world in v10.291, migrated the database(s) and EVERYTHING WORKS, again… I’m pissed enough at the short amount of development time between v10 and v11, so from now on I’ll wait a good four to six weeks before I attempt to upgrade. I view myself as being lucky, THIS TIME…

I looked at Save Points, last night, and found nothing there.

I’m not sure I even know how to read those logs; I will not, least-wise, be reading them, tonight, anyway. I’ve been in heart attack mode for 24 hours, now, because I have done nearly three years of work that has survived all the updates until now, and to lose it would have meant my exit from, at the very least, Foundry.

phi, I thank you very much for walking me through all of this. I’m back and I’m grateful to you for your help.

1 Like

Sure thing @tithenon :slight_smile: :+1:
I’m happy to help and glad that you’re back up and running in v10. Hopefully that lets you rest easy knowing your work is safe. If you’re up and running, no need to unpack the logs and look for errors now

If you do decide to upgrade to v11 in the future I’d be happy to help out again if you run into any problems. For me, personally, I will likely be finishing my current campaign in v10 or only upgrade in a month or so, yeah. Remember to always take backups before any major update :+1:

All the best, and happy gaming!

Alright, it’s one month later, hehe…

I still have not updated to v11 and won’t until Monday, July 3rd, at the earliest.

  1. Is it now safe to do so?

  2. I know I can download the most current world and module information, so that’s not problem, and I know from last month’s debacle that I can get it all back to v10, if necessary. However, my big problem was that installing V11 pretty much destroyed my worlds, before I was able, with your great help, Phi, to return them to v10. My question now becomes, is there anything I can do to safeguard my update further than just saving to my computer?

  3. Do I need to back up my information, remove the current v10 installation, then go with a fresh v11 installation, rather than trying to overlay?

Can you believe a lot of folks aren’t comfortable with the present design for v11, yet, and Foundry is already talking about v12? I guess I’m just grateful they’re including the whole of the community, but I so wish things could slow down a bit.

Thank you, again, for your time, and I look forward to hearing from you.

Hey there @tithenon :wave:

There are a few issues with v11 specifically on Forge which we are still addressing. The most notable one involves running multiple worlds with multiple Foundry licenses at the same time.

If you don’t run multiple licenses, you won’t run into that problem (multiple processes cannot access the same compendium at the same time). If you do, then you can fix it by Stopping your other game from the Forge setup screen or letting it idle before Starting a new one.

  1. As long as your system and modules are supported in v11, you can update to v11. Remember to take a backup beforehand!
  2. You can Clone your world and attempt to upgrade the clone to v11, leaving your original on v10 (by not running it). This allows you to test what will happen in a safe environment.
  3. Always make sure you have backup when moving between major versions. You do not, however, need to do anything like removing v10 installations. The steps in this doc should help you out :slight_smile:

Remember, you aren’t obligated to upgrade! If you are comfortable with your campaign setup and don’t particularly need a feature that a new version of Foundry, a system, or a module offers, then you can remain on the current version until your campaign concludes, or indefinitely.

All the best, and hope this helps!

Good morning. I finally got up the nerve to perform the steps you recommended, above, Phi, but I’m not at StoryTeller tier, so I can’t use the Game Manager to modify my individual games to upgrade my clone to v11.

The last time I attempted to upgrade, I lost everything from my Foundry installation and it took me four days to get everything up and running, again, just in time for my game. I had, of course, performed backups, but it took too long for me to get back up and running. The biggest problem was the lost of my Torg Compendium and, I’m thinking, the tiered Compendia Foundry released with 11 is what screwed everything up.

You wouldn’t happen to have any other ideas, would you? :slight_smile:

Heya @tithenon

You wouldn’t happen to have any other ideas, would you? :slight_smile:

I do, actually!

You can install v11 of Foundry on your local machine, and do an export of your v10 world from Forge. Make a backup of that export, so you have your clone in case you need to roll back.

Then, add your v10 exported world to your local Foundry worlds folder (%LocalAppData/FoundryVTT/Data/worlds), run Foundry and install the v11 version of the system for the world you’re intending to test.

You can open up your Foundry v11 with the world inside to check if everything is working fine.

If it is, then you can set your Foundry version to v11 on Forge and import your v11 world to Forge using the Import Wizard.

If something goes wrong, simply switch your Forge’s Foundry version back to v10, and re-import the backup of the v10 world you took earlier.

You can do the same with your shared compendiums, export them from Forge and add them as modules to your Foundry modules folder (%LocalAppData/FoundryVTT/Data/modules).

If any of them don’t show up in your world, check inside of their module.json file and make sure that the packs have a type attribute, you might need to replace the old entity attribute, which doesn’t work on v11.

Hope that helps! Feel free to touch sides or ask any questions if you feel stuck.
Of course, remember to make sure that your required modules and systems do actually have v11 versions.

I hadn’t even thought of working with it on my computer, first. Thank you for your awesome help, phi!!! You are awesome.

Once I get up the nerve to do this, and as you said I could probably wait and, likely, I will, I’ll let you know what happens. Thank you, again.

Alright, Phi, I’m working to go through your instructions… I put my worlds in my data/worlds/ folder and nothing shows up in my Game Worlds list in Foundry.

I tried to install my worlds on my computer from within Foundry and it won’t see the worlds. I’m updated to v10 303, not 11, and I can’t get these worlds or modules to install, period. I also went to Foundry and asked about importing worlds, and found nothing.

This is not adding to my confidence to get v11 put on.

What am I missing?


PS - I think I found it… I’ll let you know, soon.

I found all of my stuff, but there are a mess of errors. I have everything from my current v10 downloaded. It appears The One Ring, the other world I’ve been working with, is in good shape for v11, now, so instead of unloading and reloading everything, I’m simply going to try updating on The Forge, again, and see if it works better, this time. Whether or not that works, I will be unloading all my current Foundry software from my Desktop, reloading the v11 stuff, and then I’ll import my v10 backups, there. This is ridiculous and Foundry needs to get their crap together and stop changing databases, for Heaven’s sake.

…and we have achieved Launch!!! On both worlds. Compendium2Module, Nice more Dice, and Trigger Happy (which I was thinking of off’ing, anyway, since I’ve never used it) Unsupported Core Versions and nine others of the 24 modules I use are Compatibility Risks, and I got rid of another module, already, I wasn’t using, so let’s see how all of this goes. Of course, I now have to go back and reactivate all of my modules, but that won’t take long, and then I have to go in and fix the Compendiums because my folders didn’t keep; however, this is a good way for me to go back and reorganize some of the things I’ve been looking to reorganize.

Is there any way to get Forge’s Compendium Folders to restore the way I had things? I really did some hard work on those, hehe.

Hey there tithenon :wave:

I’m glad that you were able to move over to v11! :slight_smile:

I’m uncertain exactly what you mean with the compendium folders. If you were using the Compendium Folders module in v10 to get your folders created, that might not translate perfectly to the now natively supported folders in v11 (added in Release 11.293 | Foundry Virtual Tabletop)

I’d recommend installing the v11 version of the Compendium Folders module to see if this lets you keep your folder structure, since that module would have managed it in v10 originally. Hopefully that works for you!

I didn’t know there was a v11 version of Compendium Folders. Going to Foundry’s version cut out all my graphics and still nothing from Torg is organized into folders. I will have to look into the v11 version here in a minute.

Thank you, again.