What modules work in 0.7.5?

Here is a list of modules working, and not working in 0.7.5. If you feel any module is left out, comment about it ^^ I’ll make sure to add it. I only added those modules that I personally use for now. If you’re a module creator and want to notify me, just write here. ^^ I will update it, and I do realise that a lot is missing. There are 400 modules after all. I did not add many sheet modules as that would take ages to go through, if you know anything, just post ^^


  • encounter-builder
  • actually-private-rolls
  • alternative-rotation
  • journal-icon-numbers
  • better-target
  • bettertemplates
  • better-text-drawings
  • camera-follow-token
  • chat-portrait
  • combat-carousel
  • ct-effect-tooltips
  • combat-utility-belt
  • compendium-folders
  • conditional-visibility
  • condition-automation
  • dice-so-nice
  • dice-calculator
  • difficultterrain
  • drag upload
  • dynamic active effects
  • emojimancy
  • followme
  • foundry_community_macros
  • foundry-patrol
  • workshop-welcome-screen
  • fxmaster
  • healthEstimate
  • health-monitor
  • forge-vtt-shared-compendiums-hey
  • hidden-initiative
  • icu5e
  • laptop-fix
  • lmrtfy
  • colorsettings
  • lib-wrapper
  • lootsheetnpc5e
  • macroeditor
  • macro-marker
  • maestro
  • master-mirror
  • midi-qol
  • MiniMap
  • multilevel-tokens
  • mytab
  • narrator-tools
  • npcgen
  • NotYourTurn
  • parallaxia
  • pdfoundry
  • personalmarkers
  • pings
  • playlist_import
  • quick-insert
  • quicksceneview
  • rolltable-buttons
  • roofs
  • scenery
  • ShowDragDistance
  • simplefog
  • SoundBoard
  • target-enhancements
  • furnace
  • tidy5e-sheet
  • tidy-ui_game-settings
  • TinyTokens
  • token-audio
  • token-health
  • tokenmagic
  • trigger-happy
  • turnAlert
  • turnmarker
  • vehicles-and-mechanisms
  • workshop-party-unit-frames
  • Ez Roll
  • Torch

Known Trouble makers:

  • combat-enhancements

Not working:

  • DancingLights–v2.1.5;
  • Dynamic effects (Updated to Dynamic Active Effects)
  • Minor QOL (Updated to Midi QOL)
  • Mount up!
  • Deselect (It’s in-built now.)
  • Tokenizer (Not on Forge)
  • Ammo Swapper
  • Compendium Browser (Is not getting worked on.)
1 Like

Is there a way to downgrade until modules we use are compatible?

Under “My Foundry”, you can manage the configuration of Foundry. At the very bottom of the form, there is the FoundryVTT Server Version dropdown, from which you can choose the version you’re comfortable with.


@kaihangaverdener as Alarich mentions above.
I was just wondering what modules you’re talking about. Most of those modules above that don’t work are not getting updated by my knowledge. Till someone takes up the module you’re looking for, as it seems they are abandoned.

Here’s the modules listed. You can see many say “Compatibility Risk”, though there are some that are compatible such as Beyond20 companion module, Polyglot, Let Me Roll That For You! and others have no warning and have been disabled.

The modules you see enabled, apart from PopOut! were previously disabled prior to the 0.7.5 release. Torch is enabled now as I’m testing to see what works, though I think that’s reliant on some other module.

I will try enabling them and see if it works.

Ah! So, the risk you’re getting is actually not helpful in any way, it doesn’t mean anything else than it’s “missing a line”.
You should just ignore it ^^

If you’re using any of the “not working” modules above, that should be the only problematic once. You’re free to use 0.7.5 without problems! ^^

I’ll do some further testing this evening. Torch seems to work.

Modules that are working for me:

Torch version 1.1.4
Deselection version 1.4.4

I noticed that Dancing Lights has now been replaced by the functionality within version 0.7.5 of Foundry VTT and can be further improved by using the Community Lights module by the same author.

From this page: https://github.com/bryancasler/Bryans-Preferred-Modules-for-FoundryVTT

2020 Oct 22 WARNING BROKEN in 0.7.x - Unable to save game or module settings while this module is Active - Virtual Tabletop Assets - Tokenizer - A tool to help generate token “token” images and their avatars.

I can confirm this is the case in my installation. After disabling Virtual Tabletop Assets - Tokenizer v 2.2.1 I can now change and save settings. Enabling Left-Click to Release Objects means I can now remove the Deselection module.

I do believe it should’ve been fixed if you use Furnace ^^

1 Like

I do use a module called The Furnace. I ran another update of the modules today and it works as you say. Thanks for the tip!

I noticed an oddity with Left-Click to Release Objects which seemed only to work for the GM and not Trusted Players. I’ll leave Deselection enabled for now as it works.

In order for “Left-Click to Release Objects” to work, EVERY player has to enable it (in my opinion, a silly decision). That’s why enabling it as the DM doesn’t make it work for others.


Thanks for clarifying that. I agree with you, it’s silly. :laughing:

I’m having a lot of fun discovering new modules and trying them out though this update has been frustrating.

1 Like

The issue with Tokenizer is reported here:

In the meantime, a few users have created their own alternate manifest urls for this.

Try this in the meantime. Works like a charm, and Tokenize away.


Ammo Swapper is not working with 7.5. I added it to their bug list.

Excellent. The best thing you can do when you find a non-compatible module is to give them a bug report to help them get things fixed up.