Module initialization / Import not working

Hi all,

when trying to initialize the module “DSA5 Kampagne - Das Geheimnis des Drachenritters”, a TDA5 adventure, a small window appers informing that the content is being imported but nothing happens.
The window with the progress marker stays there without completing the import.

Here is what I tried so far:
I deactivated the module, uninstalled it and re-installed it, activated it again and tried to initialize it. → Same result
I did the same but using a manifest URL to reinstall the module. → Same result
I turned off all modules besides the one stated above and tried again. → Same result.

Any suggestion on how to proceed in order to get this module initialized/imported would be very appreciated.

Hey there @gideon77 :wave:

Since DSA5 Kampagne - Das Geheimnis des Drachenritters | Foundry Virtual Tabletop is a Foundry premium module, it’s unfortunately difficult to check for any errors by attempting to replicate the issue on my side.

I’d like to ask you to please check two things which will hopefully give us more information on what might be going wrong:

  • If you open the dev tools console (F12) before importing, do you see any error messages logged there?
  • If you install the module on a Foundry instance running on your local machine (with the same Foundry version), does it behave the same way?

If yes to the latter, then it might be something that would need to be brought up with the module developers’ support.

Checking the above will help us to figure out where the issue is coming in!

And if it works on your local Foundry instance, you can also use the Import Wizard to import the world to Forge (see: Importing a custom module using import wizard)

Hope that helps! Please let me know if you see an error in the console.

Hi Phi,

to your suggestions:

  • F12 did not show any important red errors, only one listed there was a warning related to the screen resolution which was originating on opening the console.
  • On my local machine Foundry and all installed modules work just fine.

But your last hint did the trick: Use the wizzard.
In my first attempt some error messages appeared as the server was still running, but after turning it off the import ran smoothly.
All initialised modulesare there and can be opened.

I wonder if next time I purchase a module I have to install it on my local machine first to get it imported by the wizzard, or if it will directly work via Forge. We will see.

Many thanks for your fast support.
Please consider this item as closed.

Thanks for confirming! :slight_smile:

It should always install, whether on Forge or on local Foundry, and if something is going wrong, we would certainly want to address that! Unfortunately it is a little difficult to determine what might’ve gone wrong. If you encounter this again with a different module, please also check the Foundry logs from, which might explain what went wrong.

Happy gaming!