Logged in today to find My Asset images near 90% broken

What is going on with this site? It seems to be getting worse every month. Yesterday everything was good, I worked on my campaign worlds and uploaded some items/creatures/etc. Now I see that the images in My Assets are showing broken image links and will not open. In addition, the worlds are all screwed up as well.

I installed Tokenizer to update/create tokens and while it has worked with little to no issues for nearly a year, as of today it isn’t working at all.

I can only figure that the Forge servers are running very slow. After 20min online I was getting ready to upload my backups (HIGHLY RECOMMENDED BASED ON SERVER PERFORMANCE OF LATE) and slowly my broken images returned to actual images. :relieved:

May be time to start shopping for a new hosting site. :disappointed_relieved:

Our Assets Provider is currently having issues: Wasabi Technologies Status - Investigating issues in us-east-1 region

Our servers on the other hand should not be slow. If you’re experiencing lag/slowness that should be the world Size or might be Browser based, as well as Module leakage and so much else.

You can go through these helping posts to keep your world healthy:

World Size Check and Trouble with Modules, How to fix/turn on your browser's hardware acceleration

These usually fix the world up, and we recommend to keep your worlds as small as possible.

If you’re still experiencing lag/slowness of some kind after that, or you don’t think that is the reason, we would love to have a look at the issue. :smiley:

Hey! Just following up: The issue has been reported as fixed, so everything should be back to normal.
Thanks for your patience and understanding!

P.s: As Kevin stated, we haven’t had any issues in a long time and performance is excellent, so if you see performance “getting worse every month”, then the issue is likely somewhere else, possibly with your world data or modules. I’d highly recommend you check those related articles Kevin posted. Thanks!