Foundry VTT setup not loading

Trying to launch my foundry, at [myworld].forge-vtt.com/setup and just have a blank page with the Foundry Logo. I was able to launch the world successfully earlier today.

I’ve been having similar problems trying to get on this evening. After a few tries, I was able to get past this screen and launch my world, but doing so just brought me to a blank page with the small Foundry logo at the top left.

Maybe a traffic issue?

Has this been resolved? I am currently having the same issue

Not as far as I know

I am having this problem also.

I’m having this too. At least I was only gonna do some prep stuff.

This seems to have been resolved now. I’m still investigating what might have caused it, and I’m keeping an eye out for it in case it happens again but it seems to work now again. sorry for the small hiccup! :bowing_man:

1 Like

Yep, working for me again!

Yeah seems better now. Thanks for the quick response!

I was having this issue but no longer! Thanks.