Forbidden Lands Game System Issue

Why isn’t the game system updating from 6.0.01 to 6.o.4. When I log into the world, there is a note that I need to update and my other Premium content isn’t usuable. I have the world set at Foundry version 8.8 but have tried at 8.6, 8.7 and lower down to 7.9. Nothing is working. My hard drive version of Foundry has Forbidden Lands updated t0 6.0.4. Is the Forge not yet supporting this version?

It is based on the global Foundry version, not the worlds.
Could you try to The Game Manager and change the version there?
Else you have done it correctly. It should be an update button in the bazaar.

If it isn’t, you can upload the module manually with the new version.

Yes, I have made the changes globally through the manager. I’ve deleted my worlds several times but always the same result, no updat to 6.0.4 ever manifests.

How do I do it manually?

Going to have to change plans and play something else soon as game night is approaching. Issue remains…the Forbidden Lands modules that I purchased don’t even show up in the module manager, I presume because the game system isn’t updating to the proper update. Very aggrevating.

This should be what you need to upload a custom version of the module