Disconnected from server repeatedly when players log on

Hi, I have two groups I run on the Forge. One, every second Monday, has no major tech issues. The other, ever second Thursday, has had 1 successful Forge session, but the last 3 have been impossible to run. When all players try to log in, many cannot load up, and after a few minutes, the server disconnects and attempts to re-establish. After a few minutes of this with some players getting into the Forge and others not, everyone gets disconnected from the server at the same time and we end up on the “oops” page.

I have downgraded to version 6.5 thinking it might have been 6.6 but that didn’t work.

I tried removing walls and using simple fog thinking it might have been the dynamic lighting overloading the system but that didn’t work.

I’ve lowered the frame rate to about 30 frames per second.

This problem is only with the one group. When I log on by myself as Gamemaster there are no issues, and with the Monday group there are no issues.

Any ideas? Many thanks!

Most likely, the issue is caused by a module you have enabled on that world that you don’t have on the other. I suggest you first try to disable all modules and see if that solves it, then you can start enabling them in small groups until you find the one that is causing the problem. If the issue is that easy to reproduce for you, you can use the module “Find The Culprit” to help you more easily find which module is causing the problem.
You can also check this thread for list of known modules that work on 0.7.5 (the latest stable) and which modules are problematic : What modules work in 0.7.5?
I hope that helps.

Thanks for the quick response.

I’m actually using the same world for both campaigns, though I will try disabling modules.

Any other possibilities?

So, I have scheduled a trial log in for my players for tomorrow night to see if we can (at least) just log on together.

I have tried turning off modules which kind of maybe helped a little, but I’ve still got a variety of issues going on here.

Screen shot 1) sometimes the drop down menus are there (you can see no actors visible)
Screen shot 2) as above (no menu for the set up visible)
Screen shot 3) no map loading and no set up menu
Screen shot 4) another no map loading
Screen shot 5) the grey screen of death (this is a common issue when logging in…)
Screen shot 6) just FYI for current versions

Other issues include not being able to move tokens.


When this happens on your side, could you have console open to screenshot? (f12 -> console top right)

This looks like a Compendium browser problem though, do you have that module installed?


I’m not too sure what that means “could you have console open to screenshot?” I’m on a Mac so I did shift+command+5 to screen shot (if that’s what you’re asking).

I’ve disable all modules and it seems to be working at the moment. I’ll get back to you after my players try to log on tomorrow night to let you know if we have some success.

All those issues sound like it might be some module causing a crash in Foundry. The console that Kevin asked for is when you press F12 (in Chrome, you can also click on the menu, “More tools” -> " Developer tools") and it will bring up a window that you can check its “Console” tab for any errors that might have occured. If a module is causing problems, it will usually appear there.
The “grey screen of death” might be if you have a massive world and a slow internet connection, the last person to report that ended up realizing they had a 200MB world which had to be entirely downloaded every time which was why it was taking time for it to show anything.
In My Foundry, you can click the ‘delete content’ button which will list you your worlds along with their sizes. A world would usually be between 10MB and 20MB, anything more than that means that you’ve done something wrong (or a module did something wrong) and that can contribute to the slow loading times/grey screen.

Thank you.

  1. Does this mean that Minor QOL is a problem?

  2. My Game World appears to be 120MB, which is probably causing issues. I would like to reduce this to the 10-20MB you have recommended. Can I vet the scenes, journal notes, and roll tables I don’t need? Or do I need something more dramatic?

  3. I have the 5E Monster Manual imported in my Actors. This probably uses up data, but this is stuff I really need. I would have thought this would be in the Compendium, but I access it through the Actors section. Would this data be included in the World data?

So, it strikes me I have 2 actions to take: get rid of problem modules, and reduce data in my world.

Many thanks.

1 Like

So first one - If you’re on 0.7.5, you should be using Midi QOL now. I see you said 0.6.6, but I have no idea if the interaction is good there.

2 & 3.
That will likely cause the problem. I would recommend putting all the actors into a compendium. The easiest way to do this is to Make a Shared Compendium from My Foundry.

Export that compendium module.

Export the world.

Copy the actors file. World Name -> data -> actors.db
Paste it into the compendium module.

Upload the compendium module

I’ve updated to 0.7.5 now.

I’ve noticed there is aa “export to compendium” function in the dropdown menu. If I just use that, then delete the Monster Manual Actors, that should do the trick? If I need to use Monsters, I can just move them from the Compendium into Actors (which if I understand this correctly, creates a kind of copy for use -maybe akin to RAM vs CPU storage).