Combat tracker not working

After downloading a few new modules my combat tracker is no longer working. I tried restarting in safe mode, but that is not helping. I tried cleaning up my actors and scenes files as they were large, but I think I made things worse.

I am afraid I might have to do a total re-installation of foundry, but don’t want to loose all my compendiums. Is there a way to export them in bulk?

Heya :wave:

You can share content between different worlds by making use of a Shared Compendium module (How to Share Content Between Worlds). This will also allow you to back up your compendiums.

As for the combat tracker, do you mean Foundry’s built-in tracker? It’s possible that may be associated with the system you’re running. Do you see any specific errors in your dev tools console (F12)?

The module turn marker is somehow messing it up. I used it for a while then uninstalled it, but foundry thinks it is still installed and looking for it.

Errors from dev console:

TypeError: An error occurred while rendering D35ECombatTracker 152. game.actors.get(…) is undefined
[Detected 1 package: system:D35E]

Did you make sure to Stop your server from The Forge after uninstalling the module?

You can also click Select Data Files to Delete in your Table Tools on that page and uninstall the module using that interface if it still appears in your data files.

The server Stop is necessary because Foundry loads modules from disk on startup.

It appears as if the error is happening in the D35E system’s combat tracker rather than in Turn Marker, so it might require a re-install of the D35E system as well

Thanks Phi. I appreciate the feedback.