World Password Problem

I have a problem. I am using foundry version 0.8.8 and WFRP 4e version 4.0.6.
I have no modules.
The issue is the following, once I load into the menu where it requires me to select a user and enter a password I may not enter the correct password, well I never had one for starters and any I try are invalid (Error 403) I tried: my admin access key and my forge password.
In addition, choosing the ‘Reset User Passwords’ option int he world settings does not work.

Please all assistance is welcome.

p.s.: All other worlds and systems work perfectly.


For any looking to solve this problem do the following steps:

  1. backup your world (export your world)
  2. delete the users file in its, located at: worlds//data/users.db
  3. use the import wizard to import the modified zip file
  4. once you are in game since it shouldn’t ask for more passwords
  5. execute the following command through console: new game.wfrp4e.migration().migrateWorld()
    5.5. COnsole can usually be accessed by pressing f12.
  6. Make new users for everyone.
1 Like

Hey @sushi, I see you’ve solved the issue quickly!
The problem was from a Foundry bug in 0.8.7 and 0.8.8, and here’s my solution to it from a different post :

I hope this helps you if it ever happens again!

That was tried and did not work as changing the core version failed and corrupted my files super bad. the method I described above is the only one that worked in my case.

Greetings! I am also having this issue. I recently purchased a license a few days ago after hearing from a friend of mine that this one was the easiest to use. I have tried the above suggestions on how to get around this problem, but to no avail. I would really like to try this program and learn more on how to use it, but it is frustrating that I have wasted 1/2 my day on trying to figure out how to access my world. Is there an easier workaround or am I just gonna have to wait for 0.8.9 to come out before I can try this program?