Uploading/Accessing PDFs

All of my modules are turned off with the exception of TheForge. I am using v10 of Foundry (and have that version selected in forge-vtt). I do not have this issue with my desktop application of Foundry VTT v10.

When I attempt to load a PDF into a Journal Entry through forge-vtt, I get an error stating: Missing PDF file. The PDF is in my assets folder and I can navigate to it and select it for upload when I create the Journal Entry.

  1. You really shouldn’t be using FoundryVTT v10 yet, it is still in Testing (currently Testing v3, Testing v4 is next, Testing v5 is slated, this is not stable at all yet)
  2. What is the name of the PDF in your Assets Library? I would bet it has some special characters in it that are messing things around.
  1. Is there somewhere else I should raise “testing” issues? As I said, I don’t have this issue with the desktop version of Foundry v10. It would be helpful (I would think) to know if the issue is on the forge-vtt side. I will freely admit I jumped the gun on advancing to v10, but my game system author updated his system files so I thought I would go ahead. So far this is the only issue I have identified that can’t be traced to a module not being compatible with v10.

  2. I was wondering if that wasn’t the issue as I was thinking about it later. I changed the name to alpha characters only (you can see the name and file location in the screenshot). I am still having the same error.

I think this is actually a module issue, look at the URL, it’s using an absolute reference that includes TWO https connection strings instead of one.

@kakaroto, any commentary here?

Yes, I just noticed the same thing. I can’t edit the final address on my side, however.

how do you search for the PDF to assign it?

When it asks for the location I navigate to my Assets folder in forge-vtt.

Using what Module? PDFoundry?

No module. v10 added the capability to attach a PDF to a Journal entry.

As often happens, they are integrating the more popular modules with each build.

That is absolutely a v10 bug that should be reported. It’s expecting the PDF to ONLY ever be in a subdirectory of FoundryVTT, this would also break with something like AWS S3 storage.

You can fake it by changing the PDF source to PDFs/CharacterHarnmaster.pdf, and have Forge fake it to FoundryVTT to you, just tested that that works.

Yes, that worked. I will post a link to this thread in the Discord channel for bug reports.

Thanks for reporting the issue and we could confirm and report the issue to Foundry. You can follow it here :

The trick to just use PDFs/CharacterHarnmaster.pdf for now as @aeristoka suggested is a good one. That works around the problem in Foundry by making it use a relative path inside the game url. At that point, the Forge captures the “file not found” error that foundry would return and instead redirects to the assets library as it finds the file there, which then works as expected for the pdf viewer.