Upgraded to 0.8.7, Now unable to access worlds/server (says password is incorrect)

Upgraded form 0.8.6 to 0.8.7 (which I didn’t think would be a big deal, since it was just bug fixes), and now I can’t access either of my worlds (keeps saying invalid password).

Is there an easy fix to this?

1 Like

There was a reason that 0.8.7 wasn’t put under the stable channel. While it’s “technically just bug fixes”, it wasn’t. There was a massive change in how authentication is done which completely broke the user management features of the Forge.
An update to the site has just been pushed which now handles both authentication mechanisms, so this should work now.
Do note that after upgrading to 0.8.7, you will not be able to recover game access if you downgrade back to 0.8.6, unless you reset all access keys, because Foundry does a migration of the user database and changes what the password field represents.

1 Like

Note by the way that we only received the 0.8.7 build from Foundry 30 minutes in advance and spent the day working on it yesterday. We also generally wait 24 to 48 hours before assigning the stable channel to a stable version because of possible last minute critical issues. 0.8.7 has already received one such “critical hotfix” a few hours after its initial release. So I would recommend you always wait a day or so before updating, always make a backup as well, and check the changelog for anything that could possibly be more than a simple bugfix.

1 Like

Glad to know that I am not the only one having this issue.

When I tried to “reset all access keys,” I receive an error message indicating that I don’t have permission to do that although it’s my account and I am the GM. What can I do to resolve that?

I’ve never heard of that error. If you’re in the setup screen, then you’re already admin with all the permissions you need. Can you screenshot the error please?

Thanks for your reply. Here is the error message:

It seems I can enter my 5E game, but not my OSE game even though they share the same password.

I noticed too that I don’t have a “disable all modules” button on my hompage like this user:

And, after trying to log into my game and returning to the Forge, I get a new error message:

I’ve never seen that error about the administrator permission. I wonder if you have disabled cookies on your browser. What browser are you using and what version? did you try in a different browser? And do you have an admin access key set ?

The “Disable all modules” button is available on the Forge if you have the Game Manager enabled (requires a Story Teller+ subscription). You get the same thing within the Foundry setup screen when you edit the world, it’s the “launch in safe mode” checkbox.

I’m unsure about that last error you showed, that tends to happen if you forcible stop the server at the same time as you open a page to it. As long as it’s not persistent, then it shouldn’t be of any concern.

Thanks for your reply.

So, I still can’t enter my OSE game either as player, which originally had no password, or as GM with my old password or with the password left blank.I push the “join game session” button and nothing happens. My 5e game works fine.

I’m using Windows 10 and the latest versions of Firefox and Chrome. I usually use Firefox but Chrome doesn’t work either. I enabled cookies on both and there was no change.

When I attempt to disable all modules (or reset passwords) on the setup screen, I get the first error message I shared “You lack server administrator permission to submit this request.” I get the same message on my desktop version of Foundry as I do on the Forge, so I suspect that this is an 8.7 bug (and I reported it on Foundry’s discord).

I set an Admin Access key to see if that makes any difference. It doesnt.

I would upload a backup version of the game, but it seems that I would have to delete the old one first and I am reluctant to do that if there is another fix.

Thanks in advance for your time.

We’ve just had another report of the issue you encountered, and doing some more research in the Foundry discord’s troubleshooting channels, it has been reported that it is indeed a bug in 0.8.7.
We’re told that the change will happen even if the error is shown (you could confirm this by also changing the description for example and reloading to see if the change stayed).
I don’t have a solution unfortunately for the OSE game unable to let you login, but the user on Discord who had the same problem as you with the “you lack server administrator permissions” also had the same problem logging into their games. We tried to debug it and it looks like the login button just doesn’t do anything at all.
At this point, I would recommend you downgrade to Foundry 0.8.6 and see if that helps. You will also need to go to the Bazaar page and do an “update all”, which might downgrade some of your systems and packages to be compatible with 0.8.6.
If you have a backup from before upgrading to 0.8.7, that’d be preferred, otherwise, you will most likely first need to reset all access keys for the worlds, and hopefully there are no other issues that come from the downgrade.
I hope that helps!

1 Like

Thanks. I appreciate your time and help.

I downgraded to 8.6 and I could log in! :smiley:
And, I tested to see if I could launch in safe mode in 8.6 and that worked too.

Thanks again!