Unable to upload files larger than ~1MB to the Assets Library

As the title suggests I’ve been unable to upload files to the Asssets Library recently. The first time I took notice was on the 12th of April and since then the situation stayed the same. I’m on 15% of my total storage limit and have a limit of 50MB per file. Before this I could upload a 31MB map in about 20 seconds or so, but now even a 8MB map doesn’t upload in 30 minutes. It starts uploading with the blue bar, processes it with the black/grey one and then stays indefinitely on the black one shown in the screenshot below (taken at the 30 minute marks). Same for the Import wizard shown as well.

The odd thing is that it uploads a file of 360KB instantly. Anything above 1MB I tested doesn’t work though. I disabled adblocker and anything that could intervene, but no dice. Also tried it on base Edge, which had the exact same behavior.

In Foundry I can manage to upload 9MB maps in 1.5 minutes or so, but the 18MB one takes 9 minutes and gives the error shown below. After that I tried to upload a small 360KB file, which went fine. Tried the same for a fresh Foundry world and did manage to upload the file but it seems slightly random and is cumbersome. My upload speed is about 25Mbit/s.

I’m honestly just puzzled at this point.

Sorry for the late reply, I just saw your post.
The filesize is likely not what’s affecting you, I would assume that the files that succeed are files that you don’t need to upload, as we do some smart optimizations and if we find the files on our server, we copy it to your assets library without requiring you to upload all of its data. The files failing are likely files that are new to us, so it does require you to upload them and that’s what fails. I don’t know why it would stay pending that way, and I don’t see any errors in your console or anything to explain it.
What browser did you try this with? And can you try a different browser to see if it makes a difference?
The error from within Foundry is different though, it’s a “API key expired or is invalid”, check your module settings within Foundry, it appears you have given it a custom API key which has now expired, or you entered invalid data in that field. As long as you’re logged into your Foundry account, you don’t need to input anything in the API Key field of the Forge module.

I hope this helps.


First of all, thanks. Your suggestion of another browser prompted me to try Firefox, where the Asset Library worked like a charm, uploading maps instantly again. As Chrome and Microsoft Edge didn’t work in the initial post I didn’t try out another, but they are kind of similar these days I suppose.

Anyhow, I then wanted to report my Chrome version, which was 101.0.4951.67. It then prompted an update to 102.0.5005.63, which I tested and works fine again as well. So most likely the fault was with the 101 Chrome version and the one before it. Still odd, but hey, my problem is solved!

As for the Forge API error, I only uploaded via Foundry for troubleshooting. I actually don’t have the Forge module enabled by default, nor did I when testing, as I always upload via the Assets Library. Which is now possible again :smiley:

If you’re running your FoundryVTT on The Forge, The Forge module is ALWAYS running (to let you access your Assets Library), whether you enable it or not. It’s part of the hosting.