Soundscape module doesn't work on The Forge?

Hi all,
I’ve been using for my local hosting a nice soundboard module called Soundscape. (GitHub - CDeenen/Soundscape) (it’s a regular Foundry module).
It’s a bit fiddly, but I find it a million times better than both, Blitz´s and Syrinscape. It takes a while to prepare your stuff but the functionality is fantastic.
I just started trialing The Forge and found I can’t get any sounds from it. When I checked the paths to each sound I realized I had to redirect the sound files to a new path inside my Asset Library. But even when redirected I get absolutely no sound from it.
I know sound IS working because when I use Blitz’s soundboard module it works.
Unfortunately this would be a deal breaker to me, since I need to use Soundscape for my games (I got
some great soundboards, plus I really dislike Syrinscape sounds).
Any ideas?

Hi! :wave:
There shouldn’t be any reason for it not to work. I see though that the module hasn’t been updated in a year, and it says in the README that it’s not actively maintained, and the last version it works with is 0.8.9. Is it perhaps that you’re using v9 on The Forge but 0.8.9 on your local Foundry, which is why it works there but not here?
If that’s not the case, perhaps @phi can have a look on Monday and see if he can find why it doesn’t work for you.
We certainly expect all modules to work equally on The Forge.

Hi again.
I am aware the module isn’t being actively developed, but it works flawlessly on my local Foundry install, which is the latest stable v9, not 8.
And in fact I tried with my players and it worked fine too.
So, the only place it ain’t working is on The Forge.
I wouldn’t mind rearranging the paths to point to my uploaded files on my asset library, but it didn’t work in spite of that, which tells me there’s something more complex that’s off.

Hey there :slight_smile:

Having spent a bit of time fiddling with soundboards myself, I can totally appreciate having a favourite!
I had a look at this and saw that the audio element created by Soundscape doesn’t use default cross origin behaviour. I’ve made an issue on the module’s repo ([BUG]Cross-origin audio sources do not play · Issue #28 · CDeenen/Soundscape · GitHub) in case it gets picked up again :slight_smile:

It works in local Foundry because your assets are available locally, but fails if your assets have a remote source (as is the case when using the Assets Library, or referencing a remote media file such as from a public S3 bucket).

I’ve made a small unofficial patch to the module which I will PM to you. You should be able to import as a custom module on the Import Wizard to use it on your game on The Forge. Make sure to tick this box:

Just a quick reply to mention that I tried your patch and it worked great. Thanks for that. I’m very impressed by your support. I’m going to play the first session with my group on The Forge tonight, and if everything goes well for the most part, I´m definitely going to stay after the trial.

Great stuff.

2 Likes

Awesome! Glad to hear it’s working for you and welcome on board! :smiley:

1 Like