Soundboard by Blitz

I’ve just come back to using Forge after a pause of some months and suddenly the module “Soundboard by Blitz” doesn’t work anymore.

I use Foundry version 10 and as far as i remember in November it worked.

When i want to open the Soundboard, the module says there is no folder configured and when i want to declare the folder it says, that the folder doesn’t exist or cannot be reached.

Hey there :wave:

We’ve had a couple of reports of errors on the current version of Soundboard that resulted in the path configuration error being displayed, but something else actually going wrong.

Soundboard 1.7.1 does work on The Forge on Foundry 10.291, but you might be running into one of those. I recommend you double check your Soundboard configuration to make sure it’s set to point to Source: Forge

The, by using the Browse button, make sure that it’s also pointed to a valid directory in your Assets Library

If you’re running into an error with the FilePicker, try to have your dev tools console (F12) open when you make the selection, and post a screenshot of any errors you might see there.

We’ve seen cases where the presence of a specific media file that can’t play can cause Soundboard to not load, so if simply re-configuring the settings to point to an existing folder doesn’t work, try creating a blank folder in your Assets Library and populating it step by step with working assets to see if you can find the culprit.

If you do encounter a specific issue with a file, please let us know here what the file type / issue in question is, as this something that has been reported but it is currently unclear whether the issue is in the module or possibly on The Forge’s side, and more information would be appreciated!

Hope this helps, please let me know if I can do more to help out

Hi, thanks for the quick reply.

I tried everything, but the error message is the same. I didn’t change any files since using the sound board the last time. I tried assigning a new, blank folder, but it still says “the folder doesn’t exist or cannot be accessed”

Alright, it’s possible that the error in question is related to the module itself. There are currently two path related issues on the module’s repo, both of which might be in play

Please give your path a look and make sure there aren’t spaces in it, since that’s currently bugged.

And then please check to see if you can spot an error in your dev tools console (F12). You’ll need to open the dev tools console, and then change the Custom SoundBoard Directory and Save Changes to get the getSounds method to trigger, which is likely where the error is coming from.

If you see any errors, please post a screenshot here!

There are no errors in the dev console.

How do i use the fix you posted?

The fix: Fix erroneous directory check by RHeynsZa · Pull Request #92 · BlitzKraig/fvtt-SoundBoard · GitHub fix might not work for you if you’re not getting an error logged to the console, but let’s try it.

You’ll need to download the zip here and install it as a custom package via the Import Wizard

If the fix there doesn’t work for you, can you please copy and paste, then run

console.log(game.settings.get('SoundBoard', 'soundboardDirectory'))
console.log(game.settings.get('SoundBoard', 'source'))

into your console and post me a screenshot of the result?

Thanks, the zip file did the trick. It works again.

Awesome, glad to hear it!