Problems With Signalling Server for Audio/Video

With both of my games I have 5 players - and when we have logged in, invariably everyone is missing 1 or 2 peoples audio/video. It is not always the same people, nor the same people after a refresh (log in, person 2 is missing person 5, on refresh they now miss person 3, and persons 1 and 4 can’t see them, etc). Everyone also from login and during refreshes, 1 or more people on any given round also gets a “Lost connection to the signalling server”. We try refreshing the page, logging completely out and back in, people clearing their caches/cookies, and even so far as me shutting down and restarting the server. And most of the time after 10 or 20 minutes of refreshes, everybody finally gets everybody else, and it’s stable for the rest of the session.

This evening, after 45 minutes of never being able to get everyone to see everyone, we gave up, and fired up a different video chat program. We prefer the smoothness and clarity of the a/v in Foundry, but this was maddening. I’ve confirmed that neither I nor anyone was running any script blockers or extreme security settings on their browsers (a mix of chrome, chromium, and firefox browsers).

Any ideas?

1 Like

Hi, that sounds like the issue that’s been plaguing Foundry since the introduction of the feature. You can read all the gory details here :
but the short story is that there is a bug in the underlying webrtc library which causes it to not send data sometimes for random reasons even after the connection is established.
My suggestion is : Install the Jitsi module (no configuration would be needed), which will use the Jitsi library and the jitsi public servers to establish the audio/video call. It will have less incidence on your bandwidth and cpu usage too, so that might help too, but you won’t have the problem you’re describing.
For more information about the difference between how the Jitsi module works and the core Audio/Video, you can read this post here : Audio/Video conferencing
I hope that helps.


I’ll give it a shot! Thanks.

Oddly, I noticed some modules were not updating - but they should have been compatible with the 0.6.5 version - except I version I was running from the list was (Latest Stable) 0.6.5, so on a lark, I reset the server version to 0.6.5 (without the latest stable parenthetical), and a couple of modules updated. So, I’ll make sure THAT wasn’t it either, but I will definitely give the jitsi module a try, too!

Update: I’ve installed the Jitsi module, and while it appears to load (brings up the A/V window), it refuses to acknowledge the default microphone, and tests with another player have showed neither Audio or Video for either of us.

Thanks for the suggestion, but I appear to either be missing something, as looking at the console view for the web page does not show any explicit errors for the jitsi connection, which appears to be connecting, but not properly feeding into the A/V.

Ah well.

And we’re sure the microphone and webcam are allowed for the website in the browser?

I, in fact, went so far to change the global settings to just allow both microphone and camera, and when I use the built in RTC, it works, but as soon as I enable the jitsi module, and the page refreshes, it shows as there is neither camera nor microphone in the a\v window. But if I go to audio/video config, the correct defaults are listed in the drop down.


Interesting follow-up: If I reset the webpage settings to default and clear the cache, and have the browser global settings to ask to allow use of microphone and camera, and I start with the jitsi module is enabled first - it does not show the pop-up asking to allow the page to use the devices. If I disable jitsi, and the default Foundry rtc is re-enabled, it does ask for the page to be allowed.

Interesting, when I tried the jitsi module, I didn’t have any such issues, it was just working. I think I already had permission to use the devices, so I don’t know, that might be it. You could poke the jitsi module developer about whether or not it has issues requesting permission.

That sounds like an excellent next step! Because as a 20 year IT manager, looking at the console, and watching what it’s doing, I am baffled. Thanks for the reply, off to search the wild issues tab of github.

So, no issues that match mine - at least, not 100%, there are some earlier issues that seem similar, but they all appear to have been resolved with the most current patches.

So, I started from scratch - I installed fresh basic installs of a couple browsers, and logged in and tested again - these without me having made any changes from the basic default settings, or installed any extensions. In all instances, the same issues occurred.

So, I tried to go directly to, and the webpage works perfectly. Interestingly, if the jitsi meeting tab is running, and I start Foundry with the jitsi module enabled, it still doesn’t ask for permission - BUT, a second microphone/camera icon appears in the URL bar of the JITSI page, as if to say, I’m recording another source.


So, I install the WebRTC Tweaks module - and go into the settings and say, use the full jitsi web interface. I refresh, I click on the in-chat link, a new tab starts up and starts a meeting, and the new meeting acquires the microphone and camera feeds without a problem.

So, I’m now even more confused. But I figured I’d share the weirdness, should anyone else stumble into a similar situation.

1 Like

Thanks for sharing, that is definitely very weird! I think I’m just going to blame the aliens on this one. :alien: