Pixels Module Download Issue

I am trying to download the Pixels module. It is giving me the error:

Metadata validation failed for module “pixels”: The file “node_modules/@systemic-games/pixels-web-connect/dist/umd/index.js” included by module pixels does not exist

It also mentions when I try to download it that there no compatibleCoreVersion.

I have downloaded the Unfullfilled Rolls module successfully already, but I can’t get the Pixels to download. I am using a Mac running Foundry v.11.31 (I tried downloading it when I had v10 and had the same issue). Any idea how I can fix this issue?

Thanks in advance for any help you can give.

Hey there :wave:

We’re aware of an issue with the Pixels module on Forge that’s currently preventing it from working. The issue is that node_modules are excluded from packages by The Forge.

The reason for this is that node_modules can include hundreds or thousands of files which aren’t needed in the final package, and are usually not added when bundling Javascript to run in the browser. Some Foundry modules include node_modules in their final packages accidentally, which can lead to poor performance and issues processing such packages on disk, which is why node_modules was excluded.

But some packages may rely on dependencies inside of node_modules. We’ve built in a change to allow node_modules for packages whose manifests specifically reference scripts that are inside of node_modules, indicating that the inclusion is intentional.

This change should be available in the next release, likely to be next week.

Thank you so much for the prompt and detailed explanation! I will look forward to the update.


Just wanted to check to see if this is still on the radar to be fixed. Thanks!

Hi there @nmajor3

The fix is available for new packages, but it would only affect any new version of the pixels module.

You can, however, get the fix for the current version of the module by installing it as a custom module.

  • From The Forge, select Install from Manifest


This will download and unzip the module to your Forge data, and include the required node_modules inside.

Our fix will work for new versions of Bazaar packages, and custom modules installed with the above method. The fix will also be made available for the Import Wizard in a future update, but using the Import Wizard will not work at the moment.

Hope that fixes it for you!

I really appreciate all your help, I hate to be a pain, but after installing the module as instructed, I am now getting this error:

Before I go through the trouble of reverting my Foundry VTT to an earlier version, I want to make sure that will solve the issue. Thanks!!

No worries :slight_smile:
You’ll need to do the installation as a custom module following the steps I outlined here: Pixels Module Download Issue - #5 by phi

Installing through the Foundry setup screen links to the package available from the Bazaar which will run into the same error as before

1 Like

You patience is commendable. It worked as promised. Thank you so much!!

1 Like

The fix is now also available for new installs from the Bazaar here