PF2E - Importing just about anything now from Compendiums

Used to work, now doesnt

Background information: (I’m a 30+ year Technologist comfy in tech)

I am running 13th Gen Intel I91390k 3.00 Ghz, 32GRam, Windows 11, Geforce RTX 4090.
I have Forge as my provider with the maximum of everything Forge can provide.
I have two internet connections a Verizon Home Service, and a Cox Business service and I have attempted to troubleshoot this issue in the following ways/

  1. Ensured that is was not my internet connection by trying to import the premium content on either of my two independent services. Also went into my office and tried from a T1 Business Connection. Same disconnect error occurs every single time.
  2. Uninstalled and reinstalled the module and tried again more than once over 3 weeks.
  3. Deactived all modules on my game server and tried to import just the Kingmaker module alone.
  4. Started another fresh server install with PF2e System…and then only the Kingmaker, then Abomination Vaults, and then Beginners Box, each separately, each attempting ot import separately. ALL failed with same error.
  5. Used both Edge and Chrome browser attempting multiple times.
  6. the Same error occurs every time: gets to 1% importing and then VTT Disconnects from Server and stalls.

Research online from google seems to suggest that this is an issue of to many calls to the server at once and then it just crashes, boots the connection and you have to refresh to try again.

I’m stuck and cannot really proceed at this point. Anyone else have this or know a way to fix?


Bump- having the same issue trying to install abomination vaults- new world, no other modules- gets to 1% and no more.

Hi there @mfrantz2361 and @platy
I’ve encountered this before with the cause being an interruption in the websocket connection between the browser and the Foundry server.

If that websocket connection fails then the import fails.

The browser does re-establish the websocket connection, but the newly established connection does not recover the import process where it left off, leaving the browser stuck at 1%.

While I can’t speak as to what is interrupting the connection, in some previous encounters users mentioned that attempting the import on another connection (such as mobile tethering) resolved the issue for them (only necessary to do for the import step).

Other users (specifically those with Spectrum routers) have found that disabling the IPv6 firewall setting on their router prevented the websocket connection from failing. Should you have a Spectrum router, you could try this.

Another workable alternative, if my recommendation if attempting the import with an alternative connection such as mobile tethering is not possible, would be to do the import on a local Foundry server and use the Import Wizard to upload the world post adventure import to Forge for hosting,