Migrating from V9 to V11

Sometime last year my party wanted to try V10.
Party gave it a test run!
We ended session at a snowy location, party’s tokens were on the board ready for battle.
Party didn’t like v10 so we Reverted to v9

It’s been nearly a year, so we attempted to migrate to V11 (with a clone of my current world)
Everything went smoothly until I logged in.
It was the same snowy location, ready for battle.
Almost like everything from my old V10 save file was brought forward.

I’m not super savvy with this kind of stuff… could someone help me?

Tried migrating v9 → v10. Reverted v10 → v9.
Year later tried v9 → v11. Game reverted all progress to the old v10 save.

Hi there :wave:

Between v10 and v11 the databases in Foundry changed. What I’ve encountered most often in other cases where users mentioned this exact issue is that the world was migrated to v11 (you mention that it was migrated to v10 and back to v9, but it’s possible that you briefly ran it in v11 and reverted back to v9 somewhere after v11 came out).

If the v11 databases exist, the new v9 and v10 data won’t get migrated to v11 when you move over. There’s an easy way to fix that, though.

Before you migrated from v9 to v11, you’ll have made an export of the world. First off, make a copy of that export so you have a safe copy.

Then, if you unzip and check inside of that export, you’ll see a data folder.

Check inside of the data folder, and you’ll likely see something similar to the image below.


To re-migrate the new v9/v10 data to v11, and get rid of the old v11 data, delete the database folders and keep the .db files.

Then, re-import the world to Forge with the Import Wizard.
When you run that world on v11, it’ll re-migrate the new v9/v10 data to v11 format, and allow you to pick up where you left off most recently.

Let me know if you have any issues, and I hope this helps!