Issues with server connection

Hello Forge team,

Over the past couple of weeks my group and I have been having some issues trying to run the game on the server. Either we get very large lag spikes, or everything becomes unresponsive and a screen refresh is the only way to get anything moving again. This happens to me as the GM even if there is no one else connected.

I already tried deleting major mismatch modules, but it hasn’t made a difference. Any other thoughts on what could be happening? Please let me know if you need additional info to help me troubleshoot.

Thanks in advance!

Just an update, I even tried disabling all mods and it still has the same issues. My internet is otherwise unaffected

It might be your GPU/RAM/CPU getting overloaded. If that is the case, and it isn’t only on your side, it would be a module issue. Trouble with Modules

Else try How to fix/turn on your browser's hardware acceleration might be involving

Could you go through World Size Check and Trouble with Modules

Thanks for the tips! None of these seemed to work for me, but I switched from Chrome to Edge and it seems to be working a little better. Maybe it has something to do with a Chrome extension?

It might be a Chrome extension, yes. You can also check on both Chrome and Edge and see if they report the same thing. Pay attention to the “Unmasked renderer” which should be your GPU. It’s possible that Edge uses your GPU and Chrome uses “SwiftShader” (software emulation of a GPU, which will be very laggy) or uses your integrated Intel GPU instead of your real/discrete GPU, so the performance is different.

Thanks a lot for the tips! This worked for those of us having the issue, but now, during the last session, a couple of the players constantly had their screens suddenly turn gray. Sometimes it happened while moving, sometimes while rolling dice, and other times they would just be stuck there while loading the screen. A refresh of the page often fixed the issue, but it would happen again quickly after.

Any idea on why that could be? They’re connecting from Peru, I don’t know if that affects anything. Thanks again!

The behavior you described is when the GPU driver crashes. This often happens lately with the Intel GPU. It wouldn’t have anything to do with the connection itself. If they are on laptops, then there’s not much that can be done, but if they have real graphics cards, there are ways to tell the browser to use the correct one. I don’t remember right now, but I think @Kevin likely has a link available to share!

Thanks for the quick reply. Yeah, they’re on laptops, no dedicated GPU. So we just won’t be able to use Forge for our sessions? Or is there some kind of workaround?

It’s not a Forge issue but a Foundry issue. Or more specifically, a GPU driver issue causing it to not work for Foundry. I think that there was one workaround that involved downgrading the GPU drivers to an older version which didn’t have the problem. The other workaround might be to purposefully disable the hardware acceleration. It will be laggy unfortunately but it won’t crash at least.
I’m unsure what else to suggest.