Import Wizard Stuck on "Generating World"

It has been like this for hours:

This is the second day I am trying and it never gets past this the Generating World stage. And sure enough, launching “My Foundry” I do indeed see the game world section is empty

The world should be migrated usually in just a few seconds. I’ve seen this happen rarely but sometimes it will fail to do it because it can’t find the file that was originally ‘uploaded’ (given access to) to Chrome.
This happens if you have the native Foundry VTT application (or nodejs server) running at the same time, since Foundry will often/periodically overwrite the database files with new files, causing the files to become inaccessible to chrome.
Make sure you stop Foundry VTT before you do the import, and try again, see if it works.
If that doesn’t help, then there might be some bug int he import wizard, please press F12 to open the browser’s dev console, and see if any errors are appearing in the console, then screenshot that and send me that image so I can see what’s wrong.


This took hours to get to this point and spew out an error (reran after closing FoundryVTT). I ended up going to bed and letting it run overnight

My prognosis would have been “no custom directories allowed” except other assets at the paths with errors imported without issue

I tried again today. Made sure the server is also not running on The Forge. Same result:

When I import is there a way to skip importing assets? It says “903 assets already uploaded” but then it takes forever to get past the “Importing Assets” stage before moving on to try and import the world.

There is no error in the import wizard from what I see. I asked about the console’s screenshot with the assumption that it never finished the “migrating world” stage, but I think that must have been because you had your local Foundry open.
It says failed to import the world though. You should see a red warning on the page itself (not in the console) which tells you why it failed to import the import. I would assume it’s because you already have the world in the forge. That’s the most likely cause I often see (Yes, I am aware that process needs to be improved with a prompt to the user, and the error message should not be in the background but should be visible in the dialog itself).
To prevent accidental overwrites, you can’t import a world if you already have it on the forge, so you need to delete your world first, then do the import again.
The missing assets you see are, I would assume, files that you do not have in your data folder, or their size is larger than the maximum upload size limit so they couldn’t be imported.
There is no way to skip importing assets, because that would open up a whole new lot of people having issues because they skipped that step. It shouldn’t take any time though if there is nothing to import, I think it’s simply migrating all the file links from the world to use the assets library, and the UI doesn’t update to show you that it’s at the world migration step.

Oh interesting. I disabled uBlock Origin. Now I see this after when I reran:


Possibly I just missed it but ublock was showing as blocking something so I reran.

Hmm, the whole Data folder is 1.88GB (naturally the vast majority of which is assets). The stuff that makes up the world itself (i.e excluding images) should only amount to around 10MB.

Also just to clarify: when I start the server, there is no world. The list is all blank. So the I don’t think I need to delete my world first. There is no world.

I see, I have uBlock Origin too but I’ve never had it block that notification before, but I know some people have had ublock doing weird things that don’t affect others either.
So… yes, now that’s quite helpful, and I assume that’s also why it takes a while for it to get to the next step, as it’s zipping the world data in order to upload it. That “File too large” error happens if you try to import a zip file (i.e: a world or module) that is over 500MB in size.
The import wizard will move each asset individually to the asset library then zip the non-media files for import. Usually that’s only the world.json and data/ and packs/ folders, which in your case, like you said, should be 10MB. I would say check the size of the world folder and see if there is any non-media file in there that would get bundled up with the database.
So if for example you had a README.txt file inside your world folder, that one would also get included in the zipped world, same for any .js/.html/.css files you have (worlds can include custom scripts or styling, as if they were modules, which is why the import wizard included any non media files in the upload).

My guess is that maybe you have some big file in there that you forgot about which isn’t a media file (png, jpg, jpeg, gif, mp4, m4v, mp3, etc…), maybe a .zip file, or something else, like a m4a for example (which isn’t supported by Foundry as a valid media extension (yet).

Hopefully that helps you figure out what is causing the generated world to end up being over 500MB in size, and once you remove the file (or move it somewhere else), it should work.

Sorry that your experience in importing your content hasn’t been as smooth and instant as for most other people :frowning:

Ah, I have 1.6GB of pdfs from the dmsguild it looks like I added to my scenes folder for reference. Removed, reimported and works.

Awesome! I’m glad we could figure it out and you got it working in the end :slight_smile:
I hope it’s all smooth sailing for you with the Forge from now on :wink: