HTTP2_PROTOCOL_ERROR when attempting to play music playlists

Hey All,

Just managed to create my first compendium module and import it into Forge successfully. The module contains my (not stream/copywrite safe) fantasy music library, which I have set up manually in the past for each world.

All of my files are encoded in .ogg format, at or around 128kpbs bit rate. They play fine on my PC, and in my local instance of Foundry (and on my RaspPi server). When I attempt to play them in one of my Forge worlds, nothing plays.

I opened up the console and managed to capture the following errors in sequence. These happen at regular intervals as the playlist attempts to preload the next track, and then fail out and try to load the next:

Foundry VTT | Loading audio element -


foundry.js:54301 Foundry VTT | Failed to load audio node: Event {isTrusted: true, type: ‘error’, target: audio, currentTarget: audio, eventPhase: 2, …}

If I manually click on the file link in the console, the audio file plays normally in another tab.

As I mentioned before, while attempting to play a shuffled playlist, this occurs on a regular basis as it goes through the playlist failing to load audio files:

I’m running:
Foundry version 0.8.9
Forbidden Lands version 7.2.0
I’ve already tried running it in Safe Mode, and the result is the same.

i want to chime in and say I’m having same issue with various music packs running .8.9 in the FFG star wars 1.6. I’ve tried several of the free music packs and sometimes I can get it to play and then it stops and I see that error in the console. I tested and went to my desktop client and no issues playing locally.

I have also run into a issue with the ffg star wars enhancements module with the opening crawl music cutting out before the end whereas on the desktop client it plays correctly.
I did mention it to the module creator as well but because it works on the desktop and not here i would mean to a issue with forge audio

So testing your particular links it works just fine:

I would ask if you have made sure the link matches 100% in your game/module. It is Case Sensitive, so would suggest pasting in the link you sent above and test.

If that doesn’t work we can have a further look at this.

I just wanted to add to this that I’m having the same issues. Playlists will progress to the next track and play nothing unless I adjust the volume manually and then it is fixed.

I can confirm that adjusting volume seems to restore the audio and the issue is not present on the desktop client (local hosting). Wondering if @kakaroto (or if there’s more than one dev?)had time to look into this issue?