Haunted by phantom module, need an exorcist to banish it (Some Help Please :-)

3 Hello; I have a pesky module that will not de-select even if I erase it from the start up menu on foundry, I tried using “Select Data Files to Delete” from the my table menu, but that tooling is not executing, I click and nothing happens etc. I could use a helping hand please. 1 2

The image you provided is from a different module. Perhaps someone reading the forum can tell from the image what it is. You could also try asking in the Foundry discord server.

Token Info Icons looks like this:

Hello, I have more info


There are 2 of them, one is probably an early version, but…

<----from my pc foundry this “token Tooltip” works, but the other is inactive and no longer works

I have no access to my game data on the forge in order to trouble shoot this, it won’t go away and I did not want to use it.

even if i erase the module off from foundry’s (forge web), it still remains

I’m a 100% about this I spent the past 2 hours trying to get rid of it, please help me wipe clean all of my game data.

I’m at a bit of a loss here.

It seems like you had an issue where you disabled the “Token Tooltip” module and it was still active somehow? But on your last image it’s clearly not active.
So if the “uninstall” button is not working:

Then since you say “Select Data Files to Delete” is not working, it might be assumed there is a problem with your files on the server. This could be something @kakaroto should take a look at.

Is the only issue that you can’t delete the module? Because it looked OK when it was not enabled. So hopefully you’re able to wait until @kakaroto checks it out.

Thank you for bringing this issue to us, guessing it’s a weird bug that could affect others as well.

As far as what you could do at this moment, if you’re unable to delete the module, then it’s probably smarter to just wait a bit.

Hello, I am showing you image from both forge and foundry from my pc. I will now log into forge and show you again

The issue has been resolved.

We did not locate the module that provided this and it was impractical to go through the list one at a time, as there had been probably almost 100 modules installed.

To anyone reading this, please install only modules that you want to use, adding all of them will most definitely lead to a bad experience.

1 Like

Why were you showing images from your PC? The Forge is completely independent from your PC, so it’s unrelated and those images were only confusing rather than helpful.
On the Forge, go back to setup and uninstall ALL modules that you don’t need. I see from your screenshot that you have a lot of unused modules. If you don’t need it, don’t install it.
You have so many modules that you obviously can’t find the one that is at fault, so from the setup page, you can edit the world and use this option to disable all of its modules :

This is more problematic. Considering the number of modules you have installed, are you giving it enough time to execute? Don’t forget that when you click it, it needs to search and parse all of the worlds, systems and modules in your user data directory to return the information to you. The more you have, the longer it will take.
Can you please confirm that it fails to show you the deletion dialog even if you wait long enough?

EDIT: Just saw @alarich answered as well before I finished posting. Thanks for helping debug the problem.

1 Like

The issue with the “Select Data Files to Delete” not working was found and will be solved (fairly) promptly.
It was an issue with a few modules that contained unexpected data, most people would not have noticed it.