GoDice Not Connecting

Has anyone else tried GoDice with Forge VTT?
The GoDice module seems all set and was integrated well. Just can not seem to make the dice app push to the foundry VTT. Just hangs…

Someone on our Discord managed to figure out the issue with GoDice a few months ago, here’s their solution:

Chrome SHOULD work fine, just need to go to chrome://flags and search bluetooth and make sure that “Web Bluetooth confirm pairing support” is ENABLED. It’s set to Default to start, and I believe Chrome’s default for this setting is DISABLED.
Only issue is I can’t replicate it for Forge VTT on Opera, but I did get it to work on Chrome.

You can read the full discussion here if you’re interested: Discord

I hope that helps.

Thank you for the response @kakaroto!

I ended up getting lucky and stumbled upon a hint that worked for me. I’m not crazy about it, but all I did was to change the Foundry site to allow insecure content, as stated in the post on reddit below. I would be very interested if someone more technical than me has an idea on how to only allow this connection through or to somehow change GoDice’s app to a secure connection.


I found I needed to turn off carrier data, and then the GoDice App would work with the local network otherwise it defaulted to address. once carrier data was disabled it worked fine and the app and corresponding Foundry Modules of Unfiltered Rolls and GoDice worked as expected.