GM Toolkit (WFRP4e) - Version Update (Issue Solved)

Hi,

Unsure how the bazaar gets the latest versions of modules but I noticed that the current version/latest version I can see is 6.0.0 and it is currently at 6.0.1 for the module GM Toolkit (WFRP4e)

I thought I would just raise this as other modules have been updated after this change and have appeared on the bazaar and was unsure if it was a bug or a certain process had not been triggered yet.

Just to note that the links for both the project and the foundry hub which are on the sidebar of the bazaar page link to a page showing latest version at 6.0.1

Thanks

Looks like 6.1.4 is the latest.

Do you have your FoundryVTT version set to the latest v10?

Check that you are running Foundry version V10 build 288.
Looks like one of the changes that was made to the manifest in 6.0.1 was that minimum version required is 288 instead of 284 for version 6.0.0

Edit: also what aeristoka just said. That they changed the minimum required version of WFRP4e from 6.1.2 to 6.1.4
image

@mushie @aeristoka My current server status is V10 Build 288, and im running the 6.1.4 version of the WFRP game system.
I’m running the latest for everything that is available on the forge.
I just don’t see an option to download the 6.0.1 version of GM Tookit module as its latest is 6.0.0 on bazaar.

Ah, ok, sorry we missed that.

Here is the issue:

Release of “6.0.1”: 6.0.1 Release (#198) · Jagusti/[email protected] · GitHub

Patch AFTERWARDS to fix the version in the module.json: Update module, download and compatibility versions (#200) · Jagusti/[email protected] · GitHub

That’s a blatant violation of Semantic Versioning. Forge downloaded the Module to The Bazaar before they did that, and there’s no way to fix that.

The Module Authors need to properly release a 6.0.2 version, then it will show up on Forge and work.

I solved the issue, I didn’t know that bazaar pulled from the latest version you set for game manager. I had it set as V10 285 while the game alone was set to V10 288. So it was only showing me updates for up to 285.
My bad :smiley:

Ah, so they got super lucky in this case, and Forge Bazaar had NOT yet pulled the Module when they pushed the updated module.json just after.

I hadn’t spotted out the very specific FoundryVTT Module version pinning, that’s a good catch.