Getting really bad lag

Hi! First time saying anything on here, hoping someone can help me figure this out. I have two worlds hosted on the Forge, but in both of them I’m experiencing some really bad lag. Everything takes between 1-2 seconds to react, whether it’s just moving around my map or attempting to click on a settings option. I’ve deleted a number of my modules and checked the size of my worlds, but nothing seems to really help.

My currently installed modules are:

  • Forien’s Quest Log
  • libWrapper
  • Loot Sheet NPC 5e
  • Show Notes
  • Simple Calendar
  • Wall Height

Any help would be appreciated!

If it is moving, I would check your internet connection to the server, you can check that over at
My account → “User Profile” → Server Region → Change Region → Test latency (on all of them)

Hopefully that gets you a bit further. If this isn’t the issue:

Try to change browser to any other Chromium based Browser, that you are not currently using. We recommend Chrome, Firefox and Edge.

There might also be some errors in your game, please check “f12 → console” when it starts lagging.

I am also experiencing this. I have the two worlds which were running fine about a week ago and now they are unusable due to lag. I have made no changes to the worlds in this time. It takes ages to loads, once loaded in everything is sluggish and the lighting effects function like a slide show, dragging and dropping tokens is painfully slow.

I’m on the European Server with 23ms latency. I have tried with Chrome and Firefox and both have make no difference.

The 1st world has many modules activated the 2nd has next to none.

Hey @onyxtears, did you get a chance to compare your Foundry settings with your local environment as we discussed yesterday on Discord?

Hey @kakaroto and @Kevin, I just want to let you both know that I’m a dumbass and hardware acceleration was turned off on my browser

Glad you got it resolved! onyxtears just told me the same thing on Discord, they had hardware acceleration disabled in their browser, and it fixed it to enable it!
Generally, Foundry will not load at all when hardware acceleration is off, but I’m guessing that a recent Chrome release made it use a CPU-only WebGL implementation, so it works, it’s just really slow and uses a lot of CPU. That would explain a lot!

Yeah, I don’t even know how long ago it was that I turned it off to have a streaming watch party. Sorry to waste your time when the solution was that simple!