Getting CORS errors when trying to access asset library

Hello. I’m getting errors accessing the forge API from my forge instance, it seems like there have been CORS issues from my domain to the domain, as the error messages state:

The error on this particular screenshot happened when I tried to upload a picture through tokenizer, but any attempt to acess my asset library from the forge instance is giving out similar errors. Are anyone else also having this issue? Normally CORS errors are server-side, does that mean an issue with Forge’s infrastructure?

Have you fully updated the module?
It should work fine usually, I’ll have a look at the module.

Disabling the module should fix this. But we’ll have a look to see if it is on our side.

That doesn’t make sense as there shouldn’t be a CORS issue for using the API. While CORS issues are generally server-side configuration problems, this isn’t the case here, as it’s configured properly, and I think the problem is that the API request fails for some other reason and you never receive the response from the server, that’s why it doesn’t have the CORS headers.
I’d be very curious to debug this more in depth with you, if you could join us on Discord and open a ticket mentioning this thread and sharing an invitation link to your game, we can try and debug it live with you in private.

Of course, I put myself at your disposal. By the way, this issue appears to only happen at late nights, and gets magically solved by morning (only to break again the next night). Another effect of this issue is that my font-faces defined in my CSS files are also not being downloaded from google, ending up on the fallback case.

At any rate, I’ll be sure to join in the discord server and contact you. Thanks a lot!