Game data limit has been reached

Enjoying the site immensely! So, predictably, playing around with rule sets and modules, I have reached the upper data limit for game data. There doesn’t seem to be a way to get to deleting rule sets or modules, and the game won’t load. I’m running the 5E, Pathfinder 2E and Starfinder rule sets with a bunch of modules. This doesn’t seem to be too excessive, so from a business model perspective, maybe consideration would be either to:

-Increase the limit or, failing that:
-Provide the capability to access the game data to remove or archive stuff you aren’t currently using.
-Or offer a tier increase to keep things as they are

The platform and ease of navigation is top notch and I feel a little extra money is worth it. You are doing a great job. The beyond20 bridge is amazing and I think that is definitely the way to go for character management. Thank you for all your work!


As of in BETA, there is a way to upgrade your account and have more space.
Over in “My account” put in: “tier:4” as your name. You’ll still be able to have a Display Name.

I think you also might be interested in
To see what the future holds for the site.

Hey @narrator, welcome to the forums!
As Kevin said, for now, just change your name to tier:3 or tier:4 to get the increase of quota. This is only while we’re in the beta phase, and I will document that since you’re not the first one with this problem.

Most of your space has been taken over by the systems and modules, since when you import a game, it will always be only the database and any assets go to the assets library (with 3GB of quota with the 4$ tier, and for 1$ extra can become 6GB for example). I just checked your account, and your worlds are taking up only 2MB, which is not so bad when your quota is 500MB total, that’s 0.4% of your quota. That’s why I think 500MB is more than enough for most people.

Now the problem, as you mentioned is with regards to systems and modules taking a lot of space (in your case, Theatre mod is the one that made it explode, which I deleted for you btw). But my plan is for all systems and modules to be installed using a different workflow in such a way that it won’t count in your quota.
As an example, if I get 1000 users, then I get 1000 copies of the dnd5e system, that’s stupid… it’s better to have it installed once, and everyone using the same copy (and having it auto-update/downgrade if the user switches to a different FVTT version, or on new releases). That will all happen with the “systems and modules installer” feature that I’ll be working on next (I’m currently working on adding a way to delete systems/modules/worlds from the my table section)

The reason for 500MB quota though when you wouldn’t need as much if all modules don’t count towards the limit, is because you would still be able to install custom modules or systems (things that are not public or exclusive to someone else’s patreon for example).

Anyways, once I have the systems/modules installer working (which won’t use up quota) along with the ability to delete worlds/systems/modules from the forge’s interface, things should feel a bit better I believe.

Thank you! Working hard to make it easy to use and @Kevin here is working hard on making tutorial videos too :slight_smile:

By the way, here’s the plan for how Story Teller tier would work, which would give more integration and an even easier use of the platform : Planned: Story Teller tier features
If you have feedback about that, let me know!

Hey @narrator, by the way, you now have a delete content tool in the “My Table” page. Let me know if it works to your liking and if you have any feedback on it.
I’ll now be working on the systems and modules installer system.

The delete content process under table tools is awesome! I especially like the orphans feature, as I had tried an import from the roll20 converter that didn’t “take” and was taking up space. The code entry for deleting modules is good to confirm your action to prevent accidental deletion as well. This promises to be the best product in the market for functionality and ease of use.

1 Like

Hi –

In my scheduled game last night, my Game Data suddenly shot up from around 20ish percent to 102%. No idea why, but my theory is it has something to do with a module. However, when I tried troubleshooting and I couldn’t identify the source. When I browse “Select Data Files to Delete” everything is taking up the normal amount of space. The sum of the file sizes is nowhere close to 500MB. I did discover there was a problem tied to adding NPC combatants to the Combat Tracker. For each NPC I added, my players were getting a “User lacks permission to delete Combatants” error.

Once my Game Data became over 100 percent, I had to delete one of my worlds to even be able to open Foundry so I could clear out most of my modules, reinstall the world, and launch it. However, my Game Data is still high – 98 percent, and I have no idea how to get it to decrease.

Thanks in advance.

Hello, I think you have the same error as our other friend.

It seems to be an error with 2 modules clashing.
@kakaroto can probably help you delete things.

Could you have a R20 converted module or something that takes space?

Or combatant? I am sorry, I took a too drastical assumption.

It seems to be a combat module that causes this.
Thought I don’t believe that was the error causing the huge blockage in space.

@humanwell that’s indeed the issue, you’re the second person with this issue and I’m aware of it and I’ll be working on preventing that kind of behavior from taking user space in the future. The issue is essentially that those errors are sent continuously and logged by Foundry in your Logs folder, which ended up with 450MB of just log files :scream:. I’ve manually deleted the logs from your account now, so you should be good again with only 10% usage.
If you could tell me which module you added which caused those errors to continuously pop to your players, that’d be helpful so I can notify the author.


Thank you and thanks to Kevin for such a quick reply and for deleting the excess info in my Logs folder. Unfortunately, I can’t say which module caused the issue, as I had added several new ones and this was the first game in which they were used. I had tested them all locally, running a player account on my laptop and my GM account on my desktop, and everything was working. The issue appeared when my players connected remotely. I will try to troubleshoot and figure out which module is causing the issue. Is there a way for me to clear my Logs folder if it happens again?

If it’s helpful, here is a list of all of the new modules I had enabled for the first time for the game in question:

Show Drag Distance
Tiny Tokens by Blitz
About Time
Combat Enhancements
Combat Utility Belt
Combat Ready!
Compendium Browser
Compendium Folders
Cycle Token Stack
Forien’s Quest Log
Forien’s Unidentified Items
Foundry Community Macros
Group Initiative
Narrator Tools
Quick Insert - Find and insert entities you need
Simplefog - Manual Fog of War
Token Mold
Token Magic FX

I believe the last time we saw this, it was Combat enhancements.
Unless it was the error with

Compendium Browser
Compendium Folders

As mentioned, these clash against each other.

Yeah, it might have been Combat Encounters. I don’t have a good enough memory!

The Compendium Browser issue causes the Foundry server itself to use a huge amount of RAM until it gets killed by the kernel for running out of memory. That has the effect of causing a disconnection from the game and everyone gets logged out. It wouldn’t be related to the Logs folder growing like that (Also, compendium Browser issue isn’t an incompatibility with another module, it’s about it trying to load all compendium packs on load, which caused the issue as it loads everything in the RAM, so the user who had created a shared compendium and had a lot of content in it, was causing the problem).

@Kevin Can you please test the Combat Encounter module, confirm it shows those errors for players, and report the issue to the author? Thanks!

When you debugged you said that it was originally:

Compendium Browser
Compendium Folders

But I can have a look. As it is the second case with those 3 modules.
But I wouldn’t assume it is Combat enhancements for now unless that is the start of all the errors.

Thanks again for your attention to this. My players and I are very appreciative. I won’t be able to test this myself for a few days.

Hey, so I am currently doing some playtesting, if you could tell me what you did in the moment, as assume this is either a Compendium thing or combat, any ideas?

It’s a combat thing for sure, the compendium browser thing was a completely different issue.
Look for error notifications from the player’s side about “User lacks permission to delete Combatants Y from parent Z”. That’s the issue that blew up their log files.

Quick update, I’ve done some light troubleshooting, but so far haven’t been able to re-create the issue. For now, I’m running without Combat Enhancements, and to be safe, also without Compendium Browser. Our most recent game went off without a hitch.

Again, I appreciate your help and your fast response to my initial issue.

1 Like

I had a very similar issue, though to be fair I haven’t spent the time to troubleshoot it - shot up to 120% Game data usage -
I just downloaded my data & have been running from local server since then…

I can’t see how to read the logs - but error / (&the other log I deleted to quickly ) logs 280MB each

Hello, this is either a Enhanched combat or Compendium browser problem @mccar66 so if you disable those 2 modules you should be fine.

You should be able to download the logs from “my foundry” -> “select data content to delete” -> Orphans

You can’t download logs in any way at the moment, you can only delete them. And yeah, it’s most certainly entirely filled by the same Combat Enhancement error of “User X can’t modify combatant Y”