Forgot my admin password for Foundry

Hello,

after three months I’m back to DMing on foundry and I forgot my admin password (tho I remember my players’ passwords). Is there anything I can do to get it back without deleting my game?

Thanks

Admin? (aka, Return to Setup) password?
Reset here: The Forge

GameMaster password? Inside FoundryVTT?

  1. Return to setup
  2. Edit World
  3. Check “Reset User Access Keys”
  4. Save World
  5. Launch world
1 Like

I’m having this problem too but it’s only affecting my WFRP game (Foundry 0.8.8, WFRP 4.1.0).
I can login to my Mutant Year Zero and Forbidden Lands games.
From the game’s login screen I’ve tried:
Return to Setup > Edit World > Reset User Passwords
But I’m still getting an Invalid Password for Gamemaster error message when I try to login with the password field left blank.
I’ve also tried resetting user passwords and starting in safe mode, but still couldn’t get in.
Which means I can’t run my game - please assist!

Sounds an awful lot like this bug in core FoundryVTT: Resetting access keys can sometimes fail (#5540) · Issues · Foundry Network / Foundry Virtual Tabletop · GitLab

A solution to that issue is here : "Wrong Password" for an account that doesn't have a password - #4 by kakaroto
That bug was marked for the 0.8.9 milestone, but it hasn’t been marked as fixed, so… unsure at this point.

I’m getting the same issue GM password invalid. I tried the 8.6 trick and it didn’t work. I also deleted and reinstalled it. Still no luck. Any Ideas?

Did you try to reset the passwords first?
First try the “Return to setup” then use the Edit World button and enable the “Reset passwords” checkbox before launching the world. I expect that to reset the passwords successfully. The 0.8.6 bug workaround is only for when the reset passwords option doesn’t work.

1 Like

@kakaroto I’m sorry to report that I did try the reset password also. I’m stuck. unless you have another idea. I just signed up for Foundry and Forge last night.

And after resetting the password, you pressed login without entering anything in the password field? When you reset it, it means there is no password anymore and you need to keep the field empty.

That was the problem. I was trying to use a password. I’m in! Great service and very helpful! I’m in now. Thank you.

No problem. You’re not the first one to think that it needs a password. Foundry used to call it “Access key” which was somewhat more intuitive for people because you can guess that there is no access key, if you didn’t set one, but it’s hard to think that there is no password.

All I get is a password prompt, there are no options to reset anything, to go to setup, etc.

Hello Keovar,

You can navigate to the setup menu, and then navigate to server tab. From there, you can reset your admin access key. Let us know if you have any other questions.