Failed to load audio node

I don´t know if it´s a Foundry problem or a Forge problem but my instance of foundry is not working properly anymore.
I was implementing audio and re-organizing my asset library and I mistakenly moved some audio files from one folder to the other.
After I opened my campaign stuff stopped working:

  • The audio tab is frozen, it only shows one single song playing and doesn´t allow me to open the playlist, regulate volume controls or anything
  • The left buttons are not clickable anymore (I can still switch using hotkeys provided by a module but clicking on the buttons with the mouse does nothing).
  • Evry 10 to 15 minutes Foundry reloads by itself giving me a 404 error.

I checked the console and the errors I could see were based on audio files not found and Foundry failed to load audio node, so I guess that´s the problem. Thing is I have no idea how to fix it.
Here´s the console log:

Yesterday I was still able to GM the session since it was a purely role-play focused session but I can clearly see this making running the game basically impossible in the future.
Is there anything I can do to fix it?


Same for me, but I make a new try by reimporting my world this morning and it worked.

Thanks for the reply :slight_smile:
Unfortunately I tried to re-import the world too but it didn´t fix the problem. Right now I´m in the process of recreating it (I had everything saved in compendiums, so it´s not TOO hard, but still a lot of links that need to be re-linked, automations that need to be re-adjusted and stuff like that).
I would very much like to find a solution to the problem though, to avoid re-creating everything…

I’d recommend you launch the world in safe mode, which will force stop all the playlists and disable all modules. That should fix whatever problem you have.
Also, check your assets library, you’d have to change your sounds to point to the right files. I’m guessing this is a foundry bug where you are playing a playlist in loop mode and none of the files work since you renamed them. Maybe clicking the loop icon on the playlist to stop it from looping could also solve your issue, it’s worth a try.

Thank you so much! I didn´t even know about the safe mode XD
Everything works now :slight_smile:

1 Like