Error file path on import

I am using the GURPS system. When I try to import a file from the character management software (GCS) into a character sheet I get an error:


Can't open this file in this folder because it contains system files

The location is


It works from other locations and it works from this location when I try the import from my local Foundry version.
So, what is so special about the Forge and this folder combination?
How can I fix this?


Heya @lordhelmet :military_helmet:

I had a look at GCS files using Forge, and I can’t replicate the issue that you’re running into, even with that specific path. If you could check in your dev tools console (F12), there might be a better error message explaining why the browser doesn’t have access to read from that folder. My guess is that the difference comes in with the browser you’re running vs local electron (which local Foundry runs on) as opposed to Forge vs Foundry, since that upload element may be different. There’s a chance if you open your local Foundry using your browser you might run into the same issue.

I don’t think that the issue is specific to the path, but rather there might be some kind of read lock on the files. That error message usually surfaces when the files are protected to prevent accidental modification, though what on your system might be marking them as protected, I wouldn’t be able to guess.

It might Window’s Defender’s Protected Folders Feature, Security Software blocking access to it, the file being In Use or Locked by another process, a browser’s security extensions, or just File Read Permissions.

My recommendation is to check for other programs that might be using that folder or the file and ending them, including local Foundry or GCS itself, though I am somewhat grasping at straws here. I’d also recommend trying a different browser and checking if that makes a difference, we’ve seen some minor0 variation between Chrome, Firefox, and OperaGX file uploads (though usually not to this extent).

Hopefully that helps a bit!

Great! That norrows it down. I was using Chrome when running into the issue. In Firefox the issue does not occur. So it seams logical that it has somthing to do with Chrome and its settings. Though the console (F12) gave no output.

@phi Do you think it has to do with Chrome permissions or with Windows permissions?

Very odd! I was using Firefox as well. Tested now on Chrome, too, but not able to replicate there either :thinking: I think you’re right, it’s some kind of combination between the file/folder local environment and a browser setting/extension.

Unfortunate that the console gave no output, but hopefully that gives you a way to work around it and get it functional :muscle:

At the very least, Forge itself isn’t opinionated about the file path.

I’d imagine it to be Windows-side in this case, but I’m not 100% certain

It seams to be a Chrome issue. Chrome blocks access to certain folders in the file system.

{base::DIR_LOCAL_APP_DATA, nullptr, kBlockAllChildren},

The full block list in Chrome is here:;l=172-235;drc=359c4471ef9ffdf94d1080815d51f28ce0302b94;bpv=0;bpt=1

1 Like

Oho, good find! That seems pretty clear