Compendium Mapper and Image Retainer not working in PF2E

Hello there,
I seem to be having an issue with the module Compendium Image Mapper (Wilco S / Compendium Image Mapper · GitLab) with in my server on the forge. I have recently migrated my servers from Molten Hosting to the forge and the module seems to be working on Version 10 in on Molten Hosting, however when I run the module in the Forge, it will run through the process as it should, however after when I check my compendium(s) the images for the monsters have not been updated. I have made sure that the compendiums are unlocked for modification as well as rebooted the server and reloaded the game. Any suggestions on how I can fix this issue? Thanks.

Hey there :wave: I’ve been trying to replicate your issue, though I run into problems on v10 even on local Foundry when testing with the Compendium Mapper module.

The specific problem I’m running into is that v10 getDocument doesn’t return data.token.img and so Image Mapper runs into TypeErrors because the code doesn’t have null checks and fails in all v10 cases I’ve tested it with.

It’s possible there’s more at play, but I wanted to double check with you:

  • Are you certain that you’re running it successfully on a v10 Foundry server?
  • And are you running on v9 or v10 Foundry on Forge at the moment?

I have encountered behaviour similar to what you described on v9 Foundry when running on the Forge: When selecting a location to check for images in, Compendium Mapper didn’t get the exact correct path from the FilePicker on Forge, but this is somewhat dependent on the source.

When selecting a source image in the Bazaar, for example, it would select bazaar/modules/caeora-maps-tokens-assets/assets/assets/tokens/Monster_Manual_Tokens/cr0-25/without-shadows rather than modules/caeora-maps-tokens-assets/assets/tokens/Monster_Manual_Tokens/cr0-25/without-shadows, so make sure to double check your path!

Thank you for that. Im going to ding into it, I ran the restore on the other server and it work, Im going to try mapping again so I can take a look at what the console spits out. Thank you so much.