Cloned world is not listed in "my games"

Hi All,

Any idea how to remove a world from “my games” that has already been deleted (multiple attempts)?
The problem is that i restored a save point of one of my games to get back a missing actor: i restored as a clone (with a different name) aiming to run it once, export a specific actor (that i want to bring back to the current game stage), and then delete it.
However, after i restored the save point as a clone, the world starting “behaving”, i.e.:

  1. it does want to be deleted (not sure what CON saving throw it has :wink:
  2. i cannot restore as a clone any other save point - the process followed on the Game Manager interface confirms that a clone has been restored, however, when refreshing any clone save-point world does not appear on “my games” list
  3. i can create new worlds, but they cannot be deleted.
  4. i cannot clone any other existing world

Please help!

Hey there :wave:

Could you please post a screenshot of what you see over in Select Data Files to Delete 's worlds tab?

If I had to guess, it sounds like worlds are being created with the wrong paths but I’d like to see if they exist in your User Data files, whether their names are the same as in your My Games list, and whether they can be deleted from here. Let’s try to see if we can get to the bottom of it :muscle:

Hi phi!,
Thanks for your reply - good point you make there.
I didnt try deleting using the “select data files to delete”. i instead tried to use the delete button in the Game Manager interface.
So, using your idea, i managed to delete the “culprit” world. That solved one problem.
However, the general problem continues:
i have 2 worlds (two games) that i DM. When i clone the one i want (using the clone button in the save points UI) it shows it on the “select data and files to delete” list, but not in my games list…
see screenshot - you will see the game ‘Chessenta S2’ in both the “background” of the screenshot as my main game and on the ‘delete data content’ list. However, its clone, Chessenta S2 restored, does not appear on my games list (and no, it’s not “hidden” behind the delete data pop-up)
I hope it makes sense the way i describe the problem.
Any help would be much appreciated.

Aha, so the clone that you restored to does not show up in your My Games list. :thinking:

Some ideas:

  • Have you tried a hard refresh with CTRL+F5?
  • Have you tried to delete that clone and then restore a backup from scratch?
  • Have you tried to turn off Game Manager temporarily, and accessed your Foundry Server directly to see if the World appears there?

If I had to guess, I’d say that something prevented all of the required fields to be created for the world to be recognized as a game, though I am not certain what.

If you still don’t have any luck with the above, do you see any errors in your dev tools console (F12)? If so, please take a screenshot of them and paste that here! :slight_smile:

Phi… unfortunately i have tried all without any luck…
console gives no errors too.
Im not sure if having updated dnd5e to 2.11 plays any role to this issue (all my worlds are dnd5e atm). I tried downgrading to check but still the cloned world does not appear on my games list.
Note that when cloning, i select ‘create new world from this point’.

Thanks for trying them out, and I’m sorry that you’re running into this. It looks like it might be a bug with restoring backups. I’ll escalate it up internally and hopefully we can find out what’s going wrong on our side.

I’ll get back to you with more info as soon as I have it!

Ah, no the version of the system you’re using wouldn’t have an impact :+1:

Hey there @ardeniosilvenes :wave:

I’m going to give some steps :slight_smile: please go through them with your dev tools console (F12) open the whole time, in case you see an error, and just confirm that you’re still not able to see the game.

Both the game not being deleted and the game not showing in your My Games list could possibly be related to the Game Manager, though it’s not immediately apparent what might be going wrong. If you are still actively encountering the issue, would you be comfortable with us testing on your account to try to nail the bug?

If you do see an error in the console during the process, please post a screenshot of it!