Cant Upload images or tokens

Ive been using Foundry for a little over 6 months, and Just today found I am completely unable to upload any images to my gameworld; no tokens, maps, or new images are added to my library after uploaded to my library despite my constant attempts to do so. Ive never had any problems with this in the past, and I had no problem uploading images as recent as last night. Ive tried restarting the server, turning all my modules on and off, but I believe this is a problem with Forge.

Can you tell us how/where you’re uploading? Is it from within Foundry itself or through the Assets Library page? And do you get an error when you do the upload, or confirmation of success but can’t find the files, etc… ? Any more details would help here in figuring out what your issue might be. Screenshots are also very helpful usually in diagnosing the issue.

Hi kakaroto,
thanks for responding so quickly
I was trying to upload token images to my asset library through foundry itself. I can still upload images through the Assets Library page, but whenever I try to upload something through foundry itself, the image is never saved or stored under my assets. There’s no error message, nor is there the usual blue banner message that pops up after a successful upload. I can see the name of the file I want to upload in the Image or Video Browser, but it never actually does anything or adds it to the image library.
Any help or advice would be appreciated, Im starting a new campaign tomorrow and Id like for things to be working

Do you have a Forge Module API Key set?

Hi aeristoka,
I havent used or set an API key, as I dont use my local installation of Foundry for assets; I upload everything directly to my asset library through Forge

You still have the Module when you’re on Forge, give it a check if you would, on Forge.

I’d recommend you try this on a blank new world. It sounds to me like it’s possible that a module is someone preventing it from working. Usually as soon as you select a file, it starts the upload. If you see the filename in that box there, it means it’s not even attempting to upload it, it just sits there. You could also press F12 to open the browser’s dev console, and screenshot any error you see in the Console tab there, when you attempt to do an upload. That might help pinpoint the culprit (and if it’s a bug in the Forge uploader, we’d be able to see what the bug is so we can fix it)
I hope that helps.

I tried generating a blank world with no modues active, still no dice. I was able to check the console and found the following error

Well the problem seemed to fix itself without my doing anything. Im not sure what exactly went wrong but thanks for the advice anyway!

Thanks for the screenshot. I’m not sure what the issue was but it seems to be that you were unable to download a required external library which the Forge needs to perform the upload. I haven’t seen such an issue before unless the Cloudflare CDN went down but that wasn’t the case (and you seemed to be the only one affected), so I’m really unsure on the cause of the issue. If it happens again, let me know, but for now, I think we can shrug it off as “a glitch in the matrix internet” that thankfully resolved itself on its own.