Cant upload anything to my server

Recently ive been trying to put some of my maps into my games, but i put upload into my assets with the map and it just sits there on upload without ever actually applying it, no error or anything.


Hi there :wave:

Are you the owner of the Forge account that these worlds belong to? If so, it might be a login issue, or there is an API key set when there shouldn’t be.

You might run into this issue if your session details are invalid, or if you’re using an invalid or expired API key in the Forge module.

I’d recommend logging out of and logging back in, to refresh your session.

Then, please also have a look inside of your Foundry world in Configure Settings and check the settings for the Forge module. If you have an API key set there, you should be able to clear it as long as the world belongs to you. If you are a GM in someone else’s world, you might need them to create an API key for you (this can be done here)

Please let me know if that helps! If not, please open your dev tools (F12) console before trying to upload a file, and check to see if you see any error messages there (please post a screenshot if you do).

I just logged out and logged back in and am still facing the issue, it just sits there when i try and upload anything to my assets like a map png, and i checked the api settings if this is what your referring to

And this is it with the attempt to upload a 2nd time , ive been on this for atleast 7 minutes with it uploading
this shows up in the debugger at the start

And i am the owner of the account that these worlds are attached to

Hmm, that’s unusual. Are you able to do any uploads to the Assets Library from the Forge site here? If there is an upload issue there, such as the quota being full, attempting to upload there should give us some more information.

And just to confirm, did you double check that you do in fact not have an API key configured on your world’s module settings? An invalid key configured there would lead to the issue and it’s a good idea to confirm it’s not set.

If possible, could I also ask if you can replicate this issue on a different browser and on an incognito browser? Sometimes a browser extension or an overzealous antivirus could lead to the API calls failing. It’s also a good idea to disable other modules during this check, just in case something else extends the Foundry FilePicker which is responsible for the upload.

Check your forge account max storage. If you have a lot of music, sounds and extraneous tokens take them off the server and only load what you use. This will make your games run better also by reducing the time for everything to load when you open access pannels.

How big are the maps file size? If you are not, save them as WEBP or reduced quality JPEG files to reduce their file size. I replaced all my token assets with WEBP vs PNG and reduced my storage by 50%.

I would suggest uploading through the interface that forge provides and then setting the image path to the file in the scene configurations.

I hate this next question but… Have you tried turning off all of your mods and attempted to upload the map? If it works, then one of your mods is conflicting.

Sorry for late response , got caught up in holiday nonsense, i have checked the API Key in settings and it is blank, i have also removed all modules and tried to upload it still fails. i also only upload maps mostly as webp or reduced quality jpegs my storage is under 50%.

Hey there @fansile :wave:

I suspect that something is interfering with the API call to upload from inside of Foundry, or the session key / browser cookies aren’t being read properly. I have two things that I’d like to ask you to please check:

  • Are you able to do the uploads directly to the Assets Library from here?
  • If possible, could I also ask if you can replicate this issue on a different browser and on an incognito browser? Sometimes a browser extension or an overzealous antivirus could lead to the API calls failing.

I tried the link you posted on the first bullet point and even then that takes forever to upload a very tiny image. i will try on a different browser and will update to see how that goes.

Edit: i have now tried it in incognito mode and still no luck.

Hm, I wonder if the uploads are timing out for whatever reason and that’s leading to the error. Have you by any chance tried uploading from a different connection, such as using mobile tethering?

I’m able to upload fine from in-world on my side on multiple regions, but it’s possible that there’s some kind of routing issue between your location and the assets server. Trying a different connection might use a different route than your normal ISP uses and could be useful information to have

at this point im losing all hope :frowning: ive tried everything u guys have said and nothing has worked, i appreciate all the help but i might just cancel my sub since we are using theater of the mind for everything anyways since i cant upload a single map

Did you get a chance to check if the issue persists with a different connection (such as mobile tethering)?

I’m sorry you’re running into an upload issue :frowning:
I know that the asset upload endpoint is working, so I think that the upload process is being blocked by software or something in the connection itself

I checked with my phone and ya it uploaded instantly, its something with my pc :frowning: