Can't enter payment info to add a subscription

Hi, I came to the conclusion that I wanted to try the Forge to host my Foundry games (have been hosting locally).

I made an account, added my Foundry license to the account, then I tried to add a subscription.

I chose Game Master tier, yearly, with no add-ons.

Put in my Address.

Preview the plan, and then continue to the stage where I should enter my payment info.

However, on that page of the pop-up, where it says Subscribe Using a Credit Card, below it is Credit or Debit Card - and a blank drop down which is not interactable. I have confirmed that stripe is allowed on the page, and go so far as to turn off all security, ad-blocking, and pop-up blocking and retried the entire process.

No luck. No matter what I try, the Credit or Debit card area remains blank and static.

I’d love to try your service, but I have no idea what is going on. If there is an obvious fix, I’d love to try it. Otherwise, I suppose I will wait for Paypal integration.

Thanks for any insight.

Hi @warlock_the_grey, and thank you for wanting to use The Forge.
I’m sorry about the experience you’ve had, you’re the first to have such a problem with the stripe payments (that I know of).
There shouldn’t be a dropdown, just a text field to enter your credit card information. This is what it should look like :

Can you try again and send me a screenshot of what you see (Ctrl-Win-S to select an area to screenshot, then just paste here and it will upload and embed it in the reply).
Can you also press F12 to get the development console of the browser and see if there are any red error messages appearing there, and screenshot that as well. You can hide any personal information from that if you want, or if you think it might be relevant, you can send it to me directly in a private message.

After seeing what you send me, maybe I’ll have a better clue as to how to help resolve this issue.

Thank you,

Well, I have no idea what’s different.

Last night, the interface box was blank and non-interactable. Didn’t have any of the default text I see in your screenshot. Which is why I thought it might be some kind of drop down.

This afternoon - despite NO CHANGES to my system or browser (same browser, back at my default high security settings) - when I got to the enter payment information - the box had the default text, and I could type in it without issue.

As I’ve used Stripe as a payment processor before, it is allowed through my security settings by default, which is why I was confused.

Nonetheless - it works now, and the subscription has processed.

Sorry to have taken your time!


Thanks for retrying and getting it to work. It must have been some temporary issue then.
Looking at the logs I get from Stripe, I can see that it only said that I created the Customer (to store billing information) but never created a SetupIntent (to store the card information for the intent to make payments). The SetupIntent is created by Stripe when the credit card field is filled and submitted, and when I saw similar things in the logs for other customers, I thought maybe someone tried to sub, then they see the preview with the total including taxes and decide not to do it, or they see the “Paypal (soon)” and decide to wait.
So maybe others were also having the same issue. It’s usually rare, but I see it from time to time that a customer is created in the Stripe dashboard with no subscription. Maybe it’s a bug from my side of the setup or maybe it’s a temporary issue with accessing Stripe servers, either way, I’m glad it works for you now.

Anyways, the task I’ll be working on next is going to be improving the payment/subscription management interface and adding support for Paypal, so if it happens to someone else, there should at least be an alternative for them.

EDIT: oh, and Welcome to The Forge :slight_smile:

Thanks for reaching out so quickly and looking into it.

And thanks for providing the service. My players have definitely gotten good use out of your chrome extension, and I subbed your Patreon to export my games from Roll20. Given that things have worked so well in those regards, decided to move to the next step and try hosting (rather than dynamic DNS local hosting for folks).

Uploading worlds now!

Thanks again!

1 Like