Can't access Setup

Hi, I’m having a bit of trouble accessing the setup page on my partner’s server. My account is set as a GM, so my understanding is that I’m supposed to be able to change the active game and such - however, if I click on ‘return to setup’ on the join screen, it just reloads that screen. I never get to the authentication page to enter the admin password.

I’d assumed at first it was something to do with my computer, but she just logged in on my PC and was able to change the active game with no problem - I’m assuming it’s something about my account?

Thanks in advance

By default, the Forge locks down the setup screen so only the game owner can access it if no password is set. This is a security measure to prevent unauthorized users from accessing the setup screen if the GM forgot to launch a world for example.
As a GM, you would indeed be able to ‘return to setup’, but the Forge would prevent you from doing so because you don’t have access to the setup page.
To fix this, the solution would be simple, as your partner to go to their game configuration and set an admin password. If an administrator password is configured, then you should be allowed to access the setup page.
Let us know if that solved your problem!

Double checked - there is an admin password already. We tried changing it, but the problem persists. Weirdly, I discovered I’m able to access the setup page and select a game to activate if there’s no game currently active - it’s only if there’s already an active game that I can’t get to the password screen at all.

That’s weird, and I’ve just setup a game on a different account, I set an admin password and launched a world, then logged in with my regular account as a DM then tried ‘return to setup’ and it did send me to the authentication page for the setup page, so it’s working as expected from my side. Unsure why it wouldn’t work on your side :thinking:
What version of Foundry is it running on, and you’re sure your account is Gamemaster (not Assistant GM for example? Not sure if it makes a difference actually…)
Perhaps @Kevin has some ideas? :thinking:

yea weirdly im having the same problem, ive got the password off of a friend of mine but the bar to imput the password is removed after half a second

If you login into the world as GM then can you still not access the ‘return to setup’ from the settings sidebar?

Weirdly I figured out that I can do it that way my only problem now is that I can’t restart the server as I’m not the owner or anything

Turns out I can get to setup from the settings sidebar inside the game, which should serve as a workaround, thank you.

Aha!!! I always thought that was how you were trying to do it. I did not actually realize that you had the option to return to setup from the join screen show up differently if you were promoted to GM. That’s definitely a bug from our side, one that I will fix shortly (actually I just fixed it, but it’s not yet released).
In the meantime, what you can have your GM do is to ‘demote to player’ your player from the Forge’s “configure players” interface (but leave your Foundry user as GM). Since you’re not using the Forge’s User Manager, then it won’t matter, but that will work around the current bug in our system.

Thanks for reporting this issue and helping us find and fix the bug!

No problem, thanks for sorting that!

I’ve just released the update with the fix. Let me know if there are further issues. Thanks!