Cannot connect to Scenes database


I’m having difficulty accessing my game world. When I try to launch the world I receive the error: "World launch failed: Failed to connect to database “scenes”: Database is not open. See the console (f12) for more details.

The error in console reads:

setup.js:1728 Error: Failed to connect to database “scenes”: Database is not open
at maybeOpened (/opt/foundryvtt/node_modules/abstract-level/abstract-level.js:133:18)
at /opt/foundryvtt/node_modules/abstract-level/abstract-level.js:160:13
at process.processTicksAndRejections (node:internal/process/task_queues:77:11)

I have no idea what this is trying to tell me or how to fix it. I’ve tried looking up the issues however all the information that I’ve found is outdated from V9. Could anyone help?

Thank you!

Hi there :wave:

This may be related to database corruption. We’ve seen a couple of cases where this has happened if the world was imported from local Foundry while Foundry was still running.

If you have a current backup of the world, a good solution would be to re-import the current backup using the Import Wizard.

If the issue persists or no backup is available, it may be possible to manually check the scenes database and fix the corruption.

In this case, could I please ask you to open a ticket in our #ticket-support channel on Discord where you will be able to privately share a zip of either the world or the scenes database? I’d have to have a look at it to determine how best to recover it. In the cases where we’ve encountered this in the past, the database’s CURRENT file pointed to an incorrect manifest, and fixing that issue solved the problem and allowed the DB to open.