Bug: Wildcard tokens using random image don't work

Currently tokens with random images that use the wildcard option don’t work because the URL is invalid. The wildcard support in FVTT is a bit more complex than the current system is using so additional work is required for it. An issue was filed in FVTT and fixed and expected for 0.5.2 which would make this easier.
I can either do the extra work now which will all be throw away later when 0.5.2 is out, or wait for 0.5.2.

Will depend on my other priorities

1 Like

I think just waiting for it is the better option <3 Though it could be a month or two, but you have enough right now :heart:

1 Like

closing as this is now fixed

I’m having trouble getting this to work. I can do it in desktop foundry, but not on here.

Example:
This is the file path I use if I want a specific orc token:
https://assets.forge-vtt.com/5f1c75356cf2dd3b8f31af29/Tokens/Orcs/Melee%20Combatants/Orc%201%20Sdotpng

(changed the last ‘.’ to dot so it would show the text)

I’m attempting to use this for wildcard, with the box checked:
https://assets.forge-vtt.com/5f1c75356cf2dd3b8f31af29/Tokens/Orcs/Melee%20Combatants/*

What am I doing wrong?

Not fully certain how wildcard can work.
When I very recently used path/guard*.png then those worked perfectly.
Maybe you’re having issues with saving the prototype token of the actor? It won’t work on existing tokens on the map I think.

1 Like

No, I don’t think so. When I place them on the map they just show up as the foundry mystery man.

Have you tried adding the .png after the wildcard character (*)?

1 Like

That’s normal when the image is not found.

It does work on The Forge, so the issue must be elsewhere.

1 Like

Yeah, totally.

Tried it with and without now.

Did you make sure to enable the “Randomize wildcard images” option in Foundry ? Or did you only change the URL ?
The procedure is this :

  • Open the actor sheet
  • Click the “Prototype Token” in the window decoration
    image
  • Set your path using the * character in the filename
  • Enable the “Randomize wildcard Images” option
    image
  • Click on “Update Token” to save your changes
    image
  • Drag&Drop the actor onto the map

Just tried again myself and it works just as expected.

1 Like

How about path/Orc*.png?

1 Like

Hey everybody. I figured out what was happening: I was copying the path from a single token, and because my folder name had spaces in it was putting in characters as placeholders.

So /Orcs/Melee Combatants/ was turning into /Orcs/Melee%20Combatants/

Once I deleted those it works just fine. Sorry for my lack of experience and thanks for the quick response.

@kakaroto why wouldn’t that just work? Because the files browser doesn’t actually understand urls that way?

Spaces in urls always turn into %20 for compatibility, so I’m not sure why this wouldn’t work.

Yeah, me either? I assumed it would too, which is why it didn’t occur to me to replace them. It totally fixed it though. Got a clearing full of Orcs now:

1 Like

Clearing full of orcs are tight!

1 Like

My guess is that the server side code that does the search in the database for assets matching the wildcard is not doing a decoding of the URL as it should. So that’s a forge bug!