Audio issues, maps not loading, and other strangeness

Hi! I have been quite happily using Forge now for a few months with not too many issues. However, over the last 24 hours some issues have been popping up that have been quite troublesome. Namely Audio has just stopped streaming and maps will stop loading after switching between one or two maps. Sometimes they work, sometimes they do not. Sometimes one audio layer will play, and another will not. Its completely random, but it seems to grow worse as you use Forge.

When I first load in after being off the site, usually it loads the map then plays the audio effects as it should. Then if I switch scenes to another map, sometimes issues will occur right then and there, sometimes it will work again - but quickly thereafter it will stop playing audio (which seems to be the first sign that things are breaking down.) The audio length will say 0:00/0:00 when this happens, which is quite odd. This is when maps will stop loading- usually getting stuck at 90% or a bit higher.

This only has started over the last 24 hours. Before this everything worked perfectly and as it should. In troubleshooting this I tried turning off all modules, just to see if some recent update caused issues but the behavior is the same running a vanilla setup. I have tried this at multiple locations- just to see if its my network. But my home (1gb down connection that is very stable when I test it) and my work location (super fast company network) the issue is the same at both locations.

I’m getting nervous 'cuz I have my weekly game tomorrow night, and I was wondering if anyone else has experienced any issues over the last day? Or if this is something that clears itself up? Right now Forge is pretty unusable.

Need a little more info here:
What version of FoundryVTT?
What Game System?
What size/length are the audio files?
Did you just upgrade your FoundryVTT verison?
Are all of your Modules/Game System(s) up to date?

I am running 0.8.7 using the latest version of the D&D5e - 1.3.5
I am up to date on all my modules - but the issue occurs even when I unload all modules and just run vanilla. And even when I just play no audio at all - maps will just get stuck loading.
The Audio files in question are one OGG file that 7.55mb and another looping song that 2.4mb.
I did upgrade to 0.8.7 the day before this occurred and it everything ran smoothly that evening. Its the next evening when I wanted to get things ready for the upcoming game that everything went weird.

Open your browser’s Dev Console (press F12), and click the “Console” tab.

Look for any Red Text, screenshot and post.

Hi! Thanks for your help. Its performing a lot better so far tonight! Although I made no changes. Uhm, A few times a song would not start streaming tho, but for the most part it seems significantly better. I wonder if its some internet thing or server side. shrug. Anyway, I did a capture of the log when it stopped streaming an audio file. There was no red text for the entire console log. I did see this warning come up several times tho-

Sadly things seemed better then suddenly got a lot worse. My game last night barely worked, players had to constantly reload the page, audio would die midway through playback and suddenly say 0:00/0:00 for the time. I turned off all modules except Dice so Nice and streamed no audio or music. We were able to finish our game, but most of the art and assets I had put together no longer were loading. What I cant figure is it all worked last week and for the 7 months until whatever update or change occurred last week to stop it. I’m hoping the 0.8.8 update might fix something, as a few of the bugs it mentions in the patch notes have specifically target audio issues that 0.8.7 has.

I’m having exactly the same issues.


this is the error message I get when my audio is stuck at 00:00/00:00

What you experience is likely this Foundry bug, fix to be released in 0.8.9: After playing and stopping a number of audio playlist tracks, additional tracks no longer begin playback correctly. (#5494) · Issues · Foundry Network / Foundry Virtual Tabletop · GitLab

Meanwhile you can use firefox to play your games and it will load fine.