A big portion of assets library files brokenlink/corrupted?

I had uploaded a collection of Tom Cartos map to use in my next session, but after a couple of server restarts suddenly all those maps have become broken files.
Other files in my asset library are fine and still show up in my scenes, any idea what’s going on?

I guess it’s not that big of a problem cause i can just reupload them but still kinda bad if they are suddenly gone just before a session.

Thanks in advance

This shouldn’t have happened unless you moved/deleted those files. Have you been re-organizing/cleaning up your Assets Library?

Take a look at one of the links, try to browse to it. See if it loads ok in the browser by itself.

I can click on the links to open up the maps and it seems to be still there but the link seems weird, in my assets library it shows them as being broken whilst I can open the file in my browser but foundry also doesn’t load them.
Also in Foundry it shows the correct path to the map but they don’t load in.

Oh, I think this might be because of the # character in the file name, can you try to add ?optimizer=disabled while opening the image itself in a browser? (or shoot me an example link to test with)

It actually has that in the url map

And it opens just fine, just foundry cant get it. I don’t know if it helps but when i try to open a scene with a “broken” map it gives me the error “Thumb generation for Scene failed: Cannot read property ‘width’ of null”

That is odd… I just tested that URL in FoundryVTT and it worked fine for me…

Edit: Oh, it’s because that was ?optimizer=disabled edit the Scene Image and check “Disable Optimizations” then save the scene. Should load in then.

Having a # in a folder name is not generally a good idea, as we’re seeing here.

Oh great, I fixed it now.
Good to know about the # as well, thank you for the help :grin:


It appears to be some interaction with the Image Optimizer on the CDN, thus when we add that ?optimizer=disabled we say to the CDN “Don’t optimize, serve me the ORIGINAL file”, and it works.

But yeah, special characters are a pretty big no-no in folder/file names, they’ll kinda work “mostly”, but then you hit something like this… :bomb:

I can confirm, yes. Usually they work, but # specifically is one that is causing issues with the optimizer.
The optimizer was disabled recently while working out some issues from the CDN provider, and was re-enabled yesterday which is why you hadn’t seen the error in that folder in the past. It’s unfortunately an issue they’ve had for over a year, and they tried to fix it last summer but it broke other special characters, so their fix was reverted again.