Site hung up after macro execute (FXMaster) [fixed]

The loading of my active scene does not finish. The site is stuck and I can`t change the scene or access any settings.

This happened after I executed a macro for FXMaster Weather effects from a shared compendium.

The site than was unresponsive and froze.
I went back to The Forge, stopped my server, restarted it. But unfortunately the site is still unresponsive.

I can see no obvious errors in the console when the site is trying to load.

Could you please help me out with this one!

When I let the site load a while on Chrome - the browser responds with


I managed to revocer my session by enabling Safe Configuration.

After a little further investigation I realized that it allways happens when I use macros created for weather affects by FXmaster under Foundry V9.

Well, I thought the issue was fixed, but it isn’t fully.
By using the Safe Configuration I can access my session again.
But whenever I activate the FXmaster module and activate a scene the browser hangs up - probably in a loop.

I cleared the cache of my browser, restarted the browser. Restarted my server on The Forge. Ran the Safe Configuration again. But still the same behavior.

Any thoughts on how to get FXMaster back to working properly?

Hey there!

Hm, if I had to guess, I’d say that the macro introduced some kind of configuration that FXMaster can’t properly execute, which causes it to crash when it tries to load the particular effects associated with that scene. Since the macro probably would have changed your scene config, refreshing the browser wouldn’t clear the changes that had been made.

You’re likely to get a specific error message in your dev tools console (F12) when the crash happens that might explain what exactly is going wrong. My suggestion would be to revert the configuration that the macro was meant to apply, or reach out to the module developers on their GitHub with the info from the error message that causes the crash if it’s not possible to revert.

You’re also welcome to post any errors you find here or in the #forge-support channel of our Discord to see if we can pick them apart.

I think you have a good point there about changing the config of the scene.

Unfortunately the console doesn’t report any error related to FXmaster.

So, I am still not seeing an angle how to approach that issue.

The key might be in understanding the macro which caused the issue in the first place, and then trying to revert it. Could you post the macro contents here?‘fxmaster.updateParticleEffects’, [{“type”:“embers”,“options”:{“scale”:1,“speed”:40,“density”:285.15,“tint”:{“apply”:true,“value”:“#ffffff”}}},{“type”:“snow”,“options”:{“scale”:1,“direction”:60,“speed”:210,“density”:203.68,“tint”:{“apply”:false,“value”:“#000000”}}}]);

Nothing fancy, just a regular Weather effects macro.

Right, makes sense. Thanks!
Are you able to disable your scenes (ie. Launch in Safe Configuration), and then right click on the scene, configure it, and remove all the FX Master effects?

After that, the scene should be safe to load without crashing the browser.

I think I found a way to solve the issue.

As mentioned before, after going for the Safe Configuration, I was able to access my session.
All modules are diabled and no scene is active (which is very important).

I than activated the FXMaster module and went to the settings.
In the FXMaster settings there is an option to disable all effects.

After that I was able to go back to all my scenes and use the FXMaster UI (trash bin) to “Clear Particel and Filter Effects” from all my scenes.

Sounds good! :+1:
Nice work