Can't see map or dice roll

The group I am with have been playing for several weeks but I am waiting to join this week. When myself and the GM went online so he could show me how it all worked I couldn’t see the map or dice rolls. He also, couldn’t see I was online but I could see all the previous chat and my character sheet. I tried signing in as another player and it was the same.

What browser were you using ? Make sure you use Chrome or Firefox (Chrome is preferred since Firefox can act weird sometimes) and make sure it’s up to date.
Hopefully that resolves the issue. If it doesn’t, maybe attach a screenshot so I can better understand the problem as I’m unsure what to make of it.

I only use Chrome. It’s up to date to the best of my knowledge.

Have you tried without modules?

Can you go to the Help menu and click the “About Chrome” to see what exact version it is ? Also make sure hardware acceleration is enabled. You can see how to do that in the FAQ in the Foundry section.

All that’s done and Chrome is upto date. It is a 2011 Mac with High Sierra installed and it can’t go any higher.

That doesn’t answer the question of what version it is. Also, you didn’t comment about the hardware acceleration part of my answer.

Sorry that was my shorthand of saying yes Hardware Acceleration is enabled. Chrome Version is 86.0.4240.111. I just did a Webgl report and it says my browser supports it.

Ok, thanks! Moving forward then.

Try @Kevin’s suggestion of disabling all modules to see if any of them was causing the issue (you would have to ask the DM to do that).

Can you also try pressing F12 (or Cmd-Shift-I maybe if you don’t have F12) to open the developer’s console and see if there are any red error messages in there and screenshot them if you find any.
I would assume there’s an error that happens that breaks the scene rendering.
If you click on the Radiant Festival Fairgrounds, does it switch to the other scene but gives the same green background ?

All Modules are disabled.

Doesn’t allow me switch to Radiant Festival Fairground.

Here is the list of errors.

Yeah, that says the canvas doesn’t exist, can you scroll back up and screenshot the first errors you see? I’m guessing it’s going to be an error about webgl not being enabled or something. I’ve seen this before and I think (though not sure) it had something to do about some GPU being blacklisted , I gotta run, maybe @Kevin can find the link that explains how to force chrome to use hardware acceleration even on some older GPUs.

For future reference: It’s in Chrome://flags search for GPU and enable “Override software rendering list” - after that my player was able to create the canvas and render it. Thanks for the help kakaroto and Kevin :slight_smile:

1 Like

Thanks @drental,
That was it, yeah, that’s what I kept forgetting what it was and didn’t manage to search the right term! :slight_smile:

So, the instructions for @david_beatrania :

  • Open this in chrome: chrome://flags/#ignore-gpu-blocklist
  • Set this option to Enabled :

The issue is that Chrome/Firefox/Etc. will blacklist certain hardware/driver combos for using Hardware Accelerated WebGL (which Foundry requires to function), and this is the easiest way to work around that
Note though that you are in this case telling Chrome “ignore acknowledged bugs with Hardware Accelerated WebGL for certain hardware/driver combos”. I don’t suppose you have the ability to update drivers on your Mac OS X though.

I hope that helps.